Canon iP5200R wireless printing problem

Discussion in 'Mac Basics and Help' started by nutan, Nov 11, 2006.

  1. nutan macrumors newbie

    Joined:
    Nov 11, 2006
    #1
    Hello,

    I am trying to set up a Canon iP5200R printer to have a wireless connection with an airport extreme and Mac Book Pro. I can get it to work with a USB connection from airport to printer but when i try to set it up totally wirelessly I get an error. The configuration tool finds the airport but says it can't connect. I have tried turning the firewall off and have installed the latest canon driver for this printer (4.1.6) but no joy. Does anyone know if a totally wireless connection is possible and how to achieve this?

    thanks for your help.

    cheers,

    Nutan.
     
  2. Ugg macrumors 68000

    Ugg

    Joined:
    Apr 7, 2003
    Location:
    Penryn
    #2
    I just got a Brother laser printer that I've connected to my airport express and it works flawlessly. One thing you might try is to remove all printer drivers and then reinstall them. That seems to have worked for some people who have problems with wireless printing.
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Let me get this straight, the cannon is not directly connected to the Extreme but is trying to wirelessly join the network? What sort of security do you have on your network? :)
     
  4. nutan thread starter macrumors newbie

    Joined:
    Nov 11, 2006
    #4
    Canon iP5200R wireless printing problem

    Yes, the canon is not directly connected to the extreme but trying to join the network wirelessly. I have WPA2 security and I've checked that I definitely used the right password when trying to join.

    In relation to the previous suggestion I have tried uninstalling and reinstalling the drivers relating to this printer. I don't know if there are others already the system that I should remove. Unfortunately it didn't fix the problem but thanks for the suggestion.
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    If you temporarily disable the wireless security, does it work? I don't see this as a long term fix but it might help us work out where the problem is stemming from. :)
     
  6. nutan thread starter macrumors newbie

    Joined:
    Nov 11, 2006
    #6
    I disabled the security and the wireless set up now completes sucessfully. It does a connectivity test at the end and reports a good connection. However, when I tried to print I get error 300 cannot connect to the printer. I tried printing from the command line using lpr -P, from Safari and from OpenOffice. :confused:
     
  7. nutan thread starter macrumors newbie

    Joined:
    Nov 11, 2006
    #7
    It works now! I followed the instructions from Canon helpdesk below, first with the firewall and WPA2 security off and as it worked fine i tried again with all the security turned back on and it still works. :)

    01.) Turn on the Mac and connect the printer via USB 02.) Go to: Macintosh HD -> Applications -> Utilities -> Printer Setup Utility 03.) Highlight the iP5200R and press the [Utility] button 04.) Selct Network from the pop-up menu 05.) Select the target printer and click the Network Settings button. The Configuration dialogue box of Canon IJ Network Tool is displayed. 06.) Select Maintenance from the Settings menu. 07.) Click Initialize under Setting Initialisation in the Maintenance Dialogue box. 08.) Clcik OK in the Settings Initialisation dialogue box. 09.) Once it has finished, please turn off the printer and disconnect it from the Mac 10.) In the Printer List, please highlight the iP5200R and select delete. 11.) Go to: Macintosh HD -> Library -> Printers 12.) Move the Canon folder to the trash can. 13.) Go to: Macintosh HD -> Library -> Receipts 14.) Move the Canon iP5200R 416.pkg to teh trash can. -Please ensure that you do not delete any other files from this folder. 15.) Restart the Mac. 16.) Download the latest version of the drivers and IJ Network Tool software from our webste here: Driver - http://software.canon-europe.com/software/0023438.asp?model= IJ Network Setup Tool - http://software.canon-europe.com/software/0022794.asp?model= 17.) Disable any antivirus or firewall software you have. Connect the printer to the Mac and turn it on. Install the drivers which you have just downloaded. 18.) Once this has finished, please reboot the Mac. 19.) When it reloads, the next step is to install the IJ Network tool, however to ensure that it's not the type of security you are using in your wireless network that is causing the issue, please could you turn off the security settings for the network. 20.) Once you have installed the IJ Network tool go to: Macintosh HD -> Library -> Printers -> Canon -> BJ PRinter -> IJ Network Tool
    21.) Select "Setup" from the "Canon IJ Network Tool" pop-up menu and "iP5200R" in "Printers" then click [OK] 22.) Select "Wireless LAN" and press [OK] -If the "Note on Network Settings" dialog box is displayed click "Wireless Connection Only" -If the "Printer Network Setup" dialog box is displayed select "Change Printer Settings" and press [OK] 23.) The setup will automatically detect your wireless access point. -If the "Access Points" dialog box is displayed then please select the target access point. -If the access point you are trying to connect to is not displayed then please try the following:
    i.) Ensure the Access point is turned on and press Update. ii.) Try moving the Printer and Access point closer together and press update.
    iii.) Ensure that the computer can communicate properly with the wireless access point.
    iv.) Check that your Access Point is not set to Stealth Mode v.)Ensure that the Access Point is set to a channle from 1 to 11. -Confirm the "Encryption" column of the selected access point. If the encryption column is blank then press [Connect]. If "WEP" or "WPA" is displayed enter the Network Password for the Access Point and press [Connect] -When using AirPort, confirm the settings in Wireless Security of AirPort Admin Utility.
    i)Select 64 bit if 40 bit WEP is selected for the Key Length in the AirPort Base Station.
    ii)Select 1 for Key ID. Otherwise the computer will not be able to communicate with the printer via the access point. 24.) The setup will automatically detect the printer -If the "Printer IP Address Setup" dialog box is displayed select "Get IP address automatically" press [Connect] 25.) When the Setup Completion dialog box is displayed disconnect the USB cable from the printer and computer and press [Next] 26.) Place the printer in the location where you will use it. 27.) Press [Next] in the "Connection Performance Measurement" dialog box. -Ensure that a tick in a green circle is displayed in "Connection performance between the printer and the access point" -If any symbol other than a tick in a green circle appears then try repoisitioning the printer or removing any obstacle that might be blocking the connection and press [Remeasurement] see the comments for suggestions of how to improve connection. -Repeat this process until the symbol of the tick in a green circle appears. 28.) Press [Finish] 29.) Now, whilst the network security is still disabled, please add the printer to the printer list. 30.) Go to: Macintosh HD -> Applications -> Utilities -Printer Setup Utility 31.) Press [Add] 32.) Press [More Printers]
    33.) From the drop down menu select Canon IJ Network 34.) Highlight the iP5200R with the MAC address after it and press [Add] 35.) Once this process has finished, please reboot the Mac. Once it reloads, ensure that your network security is still disabled and try printing, does it work? If it does, then it would indicate that it's the type of security you are using on the network that is causing the issue. As this printer was released before WPA2 was available, it may be that it's the WPA2 encryption that is causing the issue. If this is teh case, then you may wish to reconfigure the setup of your network to use a different type of encryption. Please ensure that you are using 64bit encryption. When using WPA The authentication method, passphrase, and dynamic encryption type must match on the access point, the printer, and the computer. Enter the passphrase configured on the access point (a sequence of between 8 and 63 alphanumeric characters, or a 64-character hexadecimal number). If you do not know the passphrase, refer to the manual provided with the access point, or consult its manufacturer. Select either TKIP (Basic Encryption) or AES (Secure Encryption) for the dynamic encryption method. Please note that this printer supports WPA-PSK (WPA-Personal). WPA-Enterprise is not supported.
     

Share This Page