Can't click menu items in Battlefield 3 on new RMBP (Windows)

Discussion in 'Mac and PC Games' started by alphaone, Jun 30, 2012.

  1. alphaone, Jun 30, 2012
    Last edited: Jun 30, 2012

    macrumors 6502

    Aug 12, 2003
    Hey all, I'm in the process of getting my new RMBP set up and stuff. Loaded win 7 on it and Battlefield 3 to see how it would do. Game opens fine but inside the menu while in fullscreen mode I cannot click on any menu items. The mouse moves but you just can't click anything. If you press alt+enter and go into windowed mode you can click on everything just fine, but windowed mode is no way to play a game like that. I checked around online, and lots of people seem to have had this problem, and they all seem to be on laptops. I couldn't really find any fixes though, although people seemed to think it was fixed by turning off graphics switching and putting it on dedicated manually, but there's no way to do that in windows on this computer that I am aware of. Tried both a regular mouse and the trackpad, no dice..

    Anyone else have this problem?

    Edit: With some more trial and error I've found the issue, it appears BF3 doesn't like nonstandard DPI settings in windows (I had it set to a custom higher one to make everything more normal sized (similar to what OS X does). Setting it to medium 125% (it appears it only likes medium...) allowed full menu control. Weirdness.
  2. macrumors member

    Feb 23, 2011
    Hey I had the exact same problem but I'm using Windows 8 Release Preview. I restarted the computer, and then switch to 650M only. You need to go to the Nvidia program that bootcamp put on your toolbar and I think the option is under something called PhsyX. I don't think it has much to do with graphics processing, more a physics thing, but now my BF3 works. Let me know if that works.
  3. macrumors member

    Aug 1, 2010
    Yup, it is the same thing in D3, you have to change the DPI or text size in order to see where the mouse moves.

    When I get home later i'll try the method of the poster above to see if it works.
  4. draughn101, Jun 30, 2012
    Last edited: Jun 30, 2012

    macrumors member

    Feb 23, 2011

    Hey you wouldn't happen to have a D3 guest pass would you??

    OK so I switched over to see what exactly I changed....

    Go to NVIdia Control Panel
    then 3D Settings
    then Set PhysX Configuration
    Under the pulldown select 650M, instead of autoswitch.

    If that doesn't work then Im not sure what I did to fix it, but it works for me now.
  5. macrumors newbie

    Jan 14, 2013
    Hey guys, I did change the automatic switch to Nvidia only but it still does not work. I have browsed through the internet and haven't found anyone with this problem but you. Any ideas what else may be wrong?

Share This Page