Can't copy & paste, drag & drop, or print...

Discussion in 'OS X' started by kevkersey, Dec 18, 2007.

  1. macrumors newbie

    Joined:
    Dec 18, 2007
    #1
    This is driving me crazy. I installed Leopard on my desktop (G5 Tower) and Powerbook (17" G5) and things were working great. All of a sudden, for the last few days I have not been able to copy & paste, or drag & drop on my desktop computer (laptop still works fine). I am also not able to print, and yesterday I was not able to open a particular FMP file that I just opened a few days earlier.

    My problem with not being able to drag & drop means I cannot move files to other locations, nor can I copy and paste them to another location.

    Someone suggested I empty the cache from my library directory, but I'm not sure if I should delete everything or something inparticular.

    Any suggestions or advice would be greatly appreciated.

    TIA

    Kevin
     
  2. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    What sort of install did you perform? If you create a new user account, do the problems carry over?
     
  3. thread starter macrumors newbie

    Joined:
    Dec 18, 2007
    #3
    I did a upgrade install. Same as with my PowerBook, which is working fine. Even the desktop (where I am having problems) worked fine for over a month.

    I switched users and used an account I have not used since I upgraded to Leopard and got the same problems. So it doesn't seem to be a "user" issue, but a system wide issue.

    Any suggestions?
     
  4. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Have you, by any chance, recently installed some program that enhances the Finder? This program may be incompatible with Leopard, and causing the problem you are having.
     
  5. thread starter macrumors newbie

    Joined:
    Dec 18, 2007
    #5
    The only things I have installed recently were TurboTax and FinalCutExpress, both the latest versions.

    Oh, and the software for the Harmony 670 universal remote, I think that was the last thing I installed. I believe the problems started showing up after that. Perhaps that is the culprit.

    Today I've also noticed my iDisk is not mounting. grrrrr....
     
  6. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
  7. macrumors newbie

    Joined:
    Dec 26, 2007
    #7
    Same Problem.

    I'm having the same issues, in addition to Spotlight going AWOL on me. I recently upgraded my Logitech Harmony software as well.

    It sounds like that may be the culprit...
     
  8. macrumors newbie

    Joined:
    Dec 26, 2007
    #8
    I used the Disk Utility to repair my permissions, and everything is working fine now (after a restart). Based on some threads at the Apple Support forums, the logitech software is the issue. I haven't deleted it yet, but I also haven't tried to launch it again.
     
  9. macrumors regular

    Joined:
    Aug 22, 2003
    Location:
    Dallas
    #9
    I'm having thie same exact problem, and cant print from safari or firefox, have not installed any other hardware or software, can anyone help please???!!!!
     
  10. thread starter macrumors newbie

    Joined:
    Dec 18, 2007
    #10
    Yep, that worked for me too. Logged in as root, repaired the permissions and restarted. Now everything is working again.

    I had tried logging in as another user, but that didn't help. Then I logged in as root, and everything worked. Ran the Disk Utility, repaired the permissions, rebooted and now I am able to copy, paste, drag & drop, etc.

    Thanks all for the help in finding the problem and the solution.

    Kevin
     
  11. macrumors newbie

    Joined:
    Dec 31, 2007
    #11
    Hey Guys

    Having exact same problems as all the ones above (no spotlight in top menu bar, cant drag and drop or cut and paste) although i haven't tried printing anything. I did recently uninstall Lexmark 5200 series from my machine, as i thought it was interfering with Photos hop, which has also ceased to stop working for me (this was initially the issue, but now these system functions have packed in, i'm trying to sort those before photoshop).

    When i tried to run the disk utility to repair the permissions however, it gets to only about quarter of the way, gives an estimate time f a min, and freezes....livid.

    Any suggestions on what i could try next, would be hugely appreciated.

    Thanks Guys....Happy new year to one and all!
     
  12. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #12
    Happy New Year, MIke D Green! Were you repairing permissions when it froze, or verifying the disk? If it was the former, then try verifying the drive now. Have you tried the other methods from this thread? :)
     

Share This Page