Can't delete default DNS servers in Leopard

Discussion in 'OS X' started by highlighter, Nov 4, 2007.

  1. macrumors newbie

    Joined:
    Nov 4, 2007
    #1
    I have a shiny new Macbook, but the wireless is brutally slow, so I'm trying openDNS to see if that helps. I go to system preferences -> network -> airport -> advanced -> DNS and there are two default numbers that are grayed out and cannot be selected or deleted. Anybody know how to get rid of these?
     
  2. macrumors member

    Joined:
    Nov 17, 2007
    #2
    short of editing /etc/resolv.conf and deleting the servers in there, i'm not certain. i'm looking for the same answer. i'll post if i find anything
     
  3. macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #3
    Are you clicking the "+" in the lower right hand corner?
     

    Attached Files:

  4. macrumors member

    Joined:
    Nov 17, 2007
    #4
    adding is not a problem. the "+" sign allows that. the issue is when attempting to delete the existing dns servers. they are greyed out and cannot be selected. nowhere in my network do i have static dns servers set.
     
  5. macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
  6. macrumors member

    Joined:
    Nov 17, 2007
    #6
    ah but you see that would be the easy way out. i want to be able to leave my router set to dhcp. there has to be a way to delete the default servers as they are loaded in the OS. i would prefer not to have to change settings in my router.
     
  7. macrumors newbie

    Joined:
    Aug 12, 2003
    #7
    It's not just the easy but the only way out. An evidently little-known feature of DHCP is that it provides advice regarding which DNS servers to use. That's where those grey numbers are coming from. It would be nice if Apple allowed you to ignore them, as they seem to do with Ethernet, since they are only advice.
     
  8. macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #8
    AFAIK changing your routers default DNS server has nothing to do with DHCP. I changed my routers default DNS server to openDNS and it is still providing DHCP to my network.
     
  9. sgc
    macrumors newbie

    Joined:
    Jan 2, 2008
    #9
    Hi.
    You can add a new location and use a manual ip and dns setup, or you can add a new AirPort interface with a manual ip and dns setup.

    /Stiwi.
     
  10. macrumors member

    supachicken

    Joined:
    Oct 5, 2005
    Location:
    Sydney
    #10
    They where in there in tiger too mate - just appeared as blank.
    Just put different DNS if you want and it should follow those ones after it falls over on the other one¿
     
  11. macrumors regular

    Joined:
    Feb 2, 2008
    Location:
    Ontario, Canada
    #11
    Hitting blocked sites with OpenDNS under Leopard

    I was directed here by the folks @ OpenDNS. I am also having trouble with the DNS entries in my desktop & my router under Leopard. Anyone know of a solution? or do I have to wait for Apple to resolve this in a future update? Thanks

    http://forums.opendns.com/comments.php?DiscussionID=903
     
  12. macrumors newbie

    Joined:
    Jun 2, 2008
    #12
    Fixing DNS problem on Airport under Leopard

    There is a solution for this problem that's fairly straightforward. Essentially, you just need to create a new airport service.

    1. Open System Preferences and go to Network.
    2. Click on AirPort and click advanced. Note the IPv4 Address, Subnet Mask, and Router info under TCP/IP; also note the numbers listed under DNS, except for the SOB that's causing the problem (in my case, it's the same number as my Router address).
    3. Click OK.
    4. Click on AirPort in the left pane of the Network panel, and click the tool icon below that pane. Select Make Service Inactive.
    5. Cilck the plus icon and create a new AirPort service.
    6. Click Advanced, and change Configure IPv4 to "manually." Enter the information you copied. Do the same for DNS. Click the Airport button and add your network.
    7. Click OK.
    8. Click Apply.

    Everything should be fine. Don't ask me why Apple wants to make us go through this rigamarole, unless it's to discourage us from using non-Apple routers???
     
  13. macrumors newbie

    Joined:
    Dec 28, 2007
    #13
    Re. Can't delete default DNS servers in Leopard

    After giving up on trying to delete the greyed-out addresses I thought I'd try leaving them there and simply adding the OpenDNS addresses that I wanted in their place. I rebooted and now everything works fine. In my case at least, they greyed-out ones now seem to be ignored.
     
  14. macrumors newbie

    Simon27

    Joined:
    Dec 30, 2009
    #14
    Since this thread features quite high in Google I thought I'd write up some conclusions now that it's a year later.

    On Leopard, ignore the grayed-out DNS address and add you own ones in. Then, as suggested by coffeestar on this OpenDNS thread, run the command
    Code:
    cat /etc/resolv.conf
    in Terminal. This will give you a list of your chosen DNS servers with the once suggested by the router at the end.

    On Snow Leopard, when you add new DNS servers to the list, the one suggested by the router is replaced by your first choice. Then run the same Terminal command again and you will only see the servers that you chose, but with an interesting notice at the top:

    Code:
    This file is not used by the host name and address resolution or the DNS query routing mechanisms used by most processes on this Mac OS X system.
    
    This file is automatically generated.
    Hope this is of use to anyone finding this thread who's using Leopard.
     

Share This Page