Can't fullscreen Youtube in Safari

Discussion in 'Mac Applications and Mac App Store' started by laserbeam273, Dec 27, 2011.

  1. macrumors 6502

    Joined:
    Sep 7, 2010
    Location:
    Australia
    #1
    I'm running Safari 5.1.2 and Lion. For the last couple days I've been struggling to get videos to view as fullscreen - anybody know why this is?
     
  2. macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    The most populated city in the planet
    #2
    Nope, have the same issue. Kind of annoying.
     
  3. macrumors 6502a

    BreakGuy

    Joined:
    Nov 23, 2009
    Location:
    NZ, South Pacific
    #3
    Try emptying your cache using ⌥⌘E (Option+Command+E). If that doesn't work attempt to reset Safari by clicking on 'Safari' in the menubar and selecting 'Reset Safari...'
     
  4. macrumors newbie

    Joined:
    Dec 28, 2011
    #4
    I noticed it was doing that too.
     
  5. thread starter macrumors 6502

    Joined:
    Sep 7, 2010
    Location:
    Australia
    #5
    Ah, I hate reseting Safari! Oh well, did it anyway and it works. I did it also for my MBP, but I decided to narrow down what it was. You only need to "Reset all website data".
     
  6. macrumors 6502a

    BreakGuy

    Joined:
    Nov 23, 2009
    Location:
    NZ, South Pacific
    #6
    Yea I get your frustration. Thanks for the clarification and glad it worked out for you. :)
     
  7. macrumors newbie

    Joined:
    Jan 25, 2012
    Location:
    Pakistan
    #7
    Cant full screen youtube in safari

    I had the same problem for last week, tried different forums but nothing worked out. Thanks to both of you reset safari did worked and "only the website data removal" is enough to treat this bug!
    Appreciate your time and effort
     
  8. macrumors regular

    Joined:
    Feb 21, 2011
    #8
    my solution (done it 10 times or more)

    Download flash again from the adobe site and install... Even i you have it.
    Than empty cash/cookies etc....

    reboot.

    Succes!
     
  9. macrumors member

    Joined:
    Aug 13, 2011
    Location:
    Rhode Island, USA
    #9
    Fix

    Pinch the screen back to normal so there is no zoom on the page and it will work fine. I have noticed this on a few video pages.
     
  10. macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    The most populated city in the planet
    #10
    Here is the solution which worked for me (found on another thread on this forum): Go to www.youtube.com/html5 and at bottom click the link that says "Leave HTML5 Trial." Now your YT vids will work in FS.
     
  11. macrumors regular

    andreiru

    Joined:
    Apr 18, 2008
    Location:
    Kurgan, RF
    #11
    Clearing websites fixed the issues completely and seems to have improved overall performance, YouTube aside, too.
     

Share This Page