Can't get 2 external drives to mount at the same time...

Discussion in 'Mac Basics and Help' started by JDOG_, Jun 7, 2005.

  1. JDOG_ macrumors 6502a

    JDOG_

    Joined:
    Nov 19, 2003
    Location:
    Oakland
    #1
    Ok here's the story:

    Just picked up a beauty of an external HD, a Western Digital 250GB USB 2.0 external HD and tried to get it to mount at the same time as my Maxtor 200GB USB 2.0/FireWire External HD. Won't work.

    Tried using the Maxtor in both USB & Firewire mode and neither one will mount when the Western Digital drive is mounted. By itself, either one will mount and be sucessfully usable by my iBook, but at the same time....no dice.

    I do have an iBook (933 mhz G4 with 640 Ram running Tiger), so I'm thinking it could just be an iBook or Apple Laptop limitation. Does anybody know if this is the case? I did a search and couldn't come up with anything on the forums & Applecare is closed down for the night. Any advice or knowledge would be super helpful as I would like to migrate some of the data from my old drive to the new one (to make the Firewire one bootable :)

    Thanks in advance!
     
  2. JDOG_ thread starter macrumors 6502a

    JDOG_

    Joined:
    Nov 19, 2003
    Location:
    Oakland
    #2
    Fixed...

    N/M...

    Re-downloaded the drivers (they're from 2003...guess Apple missed that one!), restarted and now it's working swimmingly.

    Now to enjoy the 450 gigs of storage....muh hahahah
     

    Attached Files:

Share This Page