Can't get icon to work (Hillegass chapter 10 pg 164-165)

Discussion in 'Mac Programming' started by John Baughman, Jul 13, 2009.

  1. macrumors member

    Joined:
    Oct 27, 2003
    #1
    Save and Open from the application works fine, but the icon is not working. I get the generic document icon. My target RaiseMan info dialog has been set as in figure 10.5.

    Not sure if this is related, but if I double click the document in the finder RaiseMan will launch but open a blank document and from that point on the document I double clicked will be locked and always open as a blank document whether from the app or otherwise. I may be getting ahead of myself in the book on this one.

    Thanks,

    John
     
  2. macrumors member

    Joined:
    May 22, 2009
    Location:
    Malmo, Sweden
    #2
    Hello John
    Not sure if I understand correctly.
    I do run through the book as well....

    I see the icon correct for the program itself, but the document has a default doc icon and nit the RaiseMan. When opening an already saved document I do get the old version without any problems. The blank document opens only when starting the RaisMan directly.

    Let me know if I can help

    /petron
     
  3. thread starter macrumors member

    Joined:
    Oct 27, 2003
    #3
    OK, the problem is first that the icon is not showing in the finder. I see the icon in the save dialog, but looking at the document in the finder it has the generic document icon instead of the icon I want to use.

    Secondly, if I open the saved document from within the program everything works and I get what I saved. If however I open the document by double clicking it, RaiseMan opens but with a blank document.

    Thirdly, after opening the document by double clicking it, it becomes locked. I cannot save any changes made in the document that was opened, nor can I do a save as with the same name. I get an error message simply saying that the document could not be saved.

    John
     
  4. macrumors member

    Joined:
    May 22, 2009
    Location:
    Malmo, Sweden
    #4
    I really do not know how to help John.

    Check the Target in Xcode and look at the Properties.

    Verify that
    Type=APPL
    Creator = rsmn
    Icon File = BBall

    I made a scree shot of the Target, and I wanted to add it here but I do not know how...

    Maybe sombody else have a clue.

    /petron
     
  5. macrumors 6502

    Joined:
    Jan 3, 2009
    #5
    Try Build->Clean and see if this helps before running the App.

    Of greater interest is **why** clean seems to get this to work. There is not very much written about "Clean" that I have found.
     
  6. macrumors 6502

    Joined:
    Jan 3, 2009
    #6

    Attached Files:

  7. macrumors member

    Joined:
    May 22, 2009
    Location:
    Malmo, Sweden
    #7
    Hi Mdeh,

    It works now, thanks for encouraging me to dig around.

    I discovered that in the
    Target, Properties, Document Types.... I missed to fill the "icon File" column. You know it is a bit long line and some more columns were hided behind the "corner"...

    /petron
     

Share This Page