Can't get Mac to access PC files over network!

Discussion in 'macOS' started by Eric1285, Feb 24, 2007.

  1. Eric1285 macrumors 6502

    Joined:
    Feb 22, 2007
    #1
    Hello all,

    I am a new mac user (I detested the thought of using a mac up until a few months ago, when I realized I could run Windows on my mac and that Apple made a mouse that could right click). I picked a MacBook Pro a couple weeks ago because I stepped on my old Vaio notebook. So far, everything's been pretty good. I am however having an issue trying to network my two computers together.

    My network setup is as follows:

    1 Windows XP Profession SP 2 machine, connected to network via ethernet
    Linksys WRT54G router
    1 MacBook Pro, OS X 10.4.8, connected via wireless

    PC IP: 192.168.1.101
    Mac IP: 192.168.1.107

    As of right now, my windows pc is set up perfectly. It can see the Mac, ping it, and access shared files. This was easy to get working, as I am very familiar with windows machines. The MacBook Pro however, is giving me some trouble.

    I am able to ping my Windows PC from the Mac, and the Mac can see it when I go to Network. If I highlight Network from the Mac, it shows a list that has "Library", "My Network", "Severs", and my windows workgroup, "Workgroup". The Library thing brings up some information on some library, the my network folder doesn't have anything in it, the servers folder shows a local server (I think the MacBook Pro itself) and the Workgroup shows my PC, named Eric. If I click on that, I get the panel with the connect button. When I click on it, it brings up the form asking for my workgroup, user name, and password. No matter what I enter (I've tried Mac user name and pw, as well as pc user name and pw) it says something about the alias not being right.

    If I try to connect using the Finder > Go > connect to server thing, the same stuff happens except that instead of saying my alias is not right, it always says that the user name / password is incorrect. Again, i've tried all different combinations of mac and pc user names, as well as simplifying my user account name in windows.

    I've tried following the guide here, as well as several other guides and tips/tricks posted on other forums. I'm still having no luck getting the mac to access the PC though. I've wasted almost half a day trying to resolve this and am beginning to get frustrated. The PC was so easy to setup and use...it actually recognized the Mac without me having to do anything at all. For some reason though, OS X just can't seem to access the PC. If anyone has any ideas or tips on how to resolve this, I would greatly appreciate it!
     
  2. SMM macrumors 65816

    SMM

    Joined:
    Sep 22, 2006
    Location:
    Tiger Mountain - WA State
    #2
    This is usually a very easy task. Are you sure you have sharing set correctly?
     
  3. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #3
  4. johnmartin78 macrumors regular

    johnmartin78

    Joined:
    Feb 10, 2007
    Location:
    Canada
    #4
    Go to your "System Prefrences",click the sharing folder and see if the appropriate boxes are checked.
     
  5. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #5
    I have Windows Sharing enabled. That's one of the first things I did. I have also already told the Mac what workgroup it's in ("WORKGROUP"). I've triple checked this, and I know it's set right because the Windows PC can clearly see the Mac in the workgroup.

    I wish it were as easy as everyone says it is, but it's just not working. The PC side works perfectly, it's gotta be a Mac issue. I've already disabled my Windows firewall, applied the appropriate sharing settings, went into some other menus to disable/enable the other things that should allow seamless networking, yet Mac OS X doesn't want to play nicely.
     
  6. Frisco macrumors 68020

    Joined:
    Sep 24, 2002
    Location:
    Utopia
    #6
    It sounds like your PC is denying access to your Mac.

    I am not sure if this is related to your problem or not, but there is a similiar issue with beta versions of Vista and Mac OS X.

    Scroll down to the bottom here
    The problem in Vista has to do with the NTLMv2 protocol.

    Here is how some Vista users resolved the problem and were able to share equally between Mac and PC. Link
     
  7. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #7
    I'm not running Vista, I don't think that applies. I'll try it if no other solutions come up.

     
  8. SMM macrumors 65816

    SMM

    Joined:
    Sep 22, 2006
    Location:
    Tiger Mountain - WA State
    #8
    Whoever took the time to put that together, "You are a steely-eyed computer pro!" Very well done, indeed.
     
  9. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #9
    So I shared out C:\TEMP on my XP SP2 box (first screen shot below).

    When I connect to it via COMMAND-K and typing in smb://ipaddress from my MacBook Pro, I get an authentication box.

    Regardless of what I type (i.e. any username/password works), I'm able to connect to the TEMP share.

    Can you post a screenshot of your XP share?
     

    Attached Files:

  10. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #10
    If I try to use command-k, I only get the authentication box, I don't get that thing that asks you which volume you would like to connect to. Then, no matter what I enter, it tells me the user name/password is invalid. The shared properties dialog of my shared folder on the pc has the share button checked, the allow network users to change my files checked, and all my other Windows settings should be correct as well (I've gone through and followed the directions in about 4-5 different guides, and they're all pretty much the same). The folder is in my C: directory and is named "Shared".
     
  11. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #11
    Try this as a test:

    In Windows Explorer, go to Tools | Folder Options | View, scroll down to the very bottom and uncheck "Use simple file sharing (Recommended)". Then click OK.

    Go back to your share, right-click on it, click the Permissions button and see what's there. See if the group "Everyone" has at least read access.
     
  12. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #12
    If I right click on the folder, I don't get a permissions option. However, if I open the folder and right click > properties > security tab, Under Group or user names, I do have Everyone.
     
  13. Frisco macrumors 68020

    Joined:
    Sep 24, 2002
    Location:
    Utopia
    #13
    Okay I have come across some people who have the same issue as you. There are two solutions to try. You can read about them Here

    In particular pay attention to the 2nd and 6th post in this thread.

    I hope one of these tips helps you out...Good Luck!

    If that's no help you can also try uninstalling then reinstalling the File and Printer Sharing for Microsoft Networks as described in the 4th post Here
     
  14. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #14
    Yeah, I've already tried those two options listed in that post. I think I've tried everything posted on that board already. I've created a thread there too, but Joel hasn't had time to reply yet. I'm going to try uninstalling and reinstalling Windows file and printer sharing next.
     
  15. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #15
    I just tried uninstalling and reinstalling my network adapter on the Windows PC. I also changed my workgroup name from WORKGROUP to HOME. The problem still exists though. I try logging on either from the Macintosh HD icon on the desktop and then going to Network, or from Go > Connect to Server, and nothing works.
     
  16. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #16
    Well, I finally got it to work. I had to configure some stuff in XP's registry, but now everything works fine. Unfortunately, I think I'm going to have to reinstall OS X because I made some changes to the security stuff using Terminal when i was trying to get everything to work, and I don't know how to undo them. Plus, i need to change the partition size for my BootCamp drive, since I now realize that OS X and Front Row will be much better for my multimedia, so I would rather have it on the OS X partition and only use the XP partition for applications.
     
  17. Frisco macrumors 68020

    Joined:
    Sep 24, 2002
    Location:
    Utopia
    #17
    Well congrats on finally getting it to work! I am surprised at all the trouble you had to endure. What did you change in the registry that fixed the problem?
     
  18. SMM macrumors 65816

    SMM

    Joined:
    Sep 22, 2006
    Location:
    Tiger Mountain - WA State
    #18
    Post what you changed so some other poor soul can save themselves a lot of troubleshooting time. I would also like to offer a suggestion. I notice you have named things temp, home, and left defaults names like workgroup. Temp and Home have special meaning in Windows and Unix. It is generally considered poor form to use them out of context. Just a suggestion - no rule against it.
     
  19. Eric1285 thread starter macrumors 6502

    Joined:
    Feb 22, 2007
    #19
    Well first I had to download Windows Resource Kit Tools. From that, I used the Command Shell and entered the following commands:

    ntrights +r SeNetworkLogonRight -u Guest
    ntrights -r SeDenyNetworkLogonRight -u Guest

    Then, I went into the registry editor and set the following:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    Click on "restrictanonymous" and change the value to 1.

    After that, I reboot the Windows PC and once it was running, everything worked!
     

Share This Page