Can't get my iPod Touch to connect to my wireless networkher

Discussion in 'iPod touch' started by tigerfan1988, Nov 2, 2008.

  1. macrumors member

    Joined:
    Nov 2, 2008
    #1
    I just picked up a 2G iPod Touch the other day. Overall, I love the thing. However, I am having issues with getting it to work with my wireless network here at home (it works just fine at other networks). Some basic information:

    - My router previously had WEP encryption but was upgraded to WPA today (after a firmware upgrade)
    - My iPod Touch wifi works just fine with encryption off on my network.
    - My iPod Touch says it is connected to the network and the bars show up in the top left. However, when I take a look at the IP, it is clearly wrong (something like 169. when it should be 192.). There are no DNS settings etc.
    - I have a Linksys Wireless B-Router.

    I've tried resetting the modem and router, resetting the iPod Touch's network settings, toggling wifi on/off etc. Is there anything I can do to get this thing working with this router? Or should I go out and buy a Wireless G-Router? Thanks
     
  2. macrumors 6502

    Joined:
    May 19, 2008
    #2
    I've had a similar problem. My touch 1G has no problems, but my 2G has issues with WPA (no problem with WEP). Sometimes it will connect when WPA is used and sometimes it won't. I have no idea what the problem is. My temp solution was to go with the less secure WEP setting
     
  3. macrumors regular

    Joined:
    Aug 23, 2008
    Location:
    California
    #3
    I have the exact same problem hopefully the new 2.2 firmware fixes this.
     
  4. thread starter macrumors member

    Joined:
    Nov 2, 2008
    #4
    I ended up restoring my iPod to the factory default settings, and then bought and hooked up a new Linksys WRT54GL router. Now the iPod connects flawlessly to the WiFi network with WPA2 encryption enabled. So my issue with it not connecting is solved. I don't know that this will work for everyone, but I'd say for those who really want it to work at home, it's worth a shot, since the router is only $49 on sale and is much faster than Wireless-B.
     
  5. macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #5
    The wifi on my 2G Touch is really buggy, won't connect most of the time. And then half the time it says it has connected, it really hasn't. This is with multiple networks.

    My 1G Touch was never like this. Hopefully the next update will fix it.
     
  6. macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    The most populated city in the planet
    #6
    I do not encounter this problem. I will agree with that my 1g connected insstantly while my 2nd gen takes about 5 minutes to connect.
     
  7. macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #7
    Even with such a delay, this really makes it inconvenient for me. The iPod Touch is a great device for quickly checking email or a web site. But if I have to fidget with the wifi settings or wait 5 minutes, then it would be faster for me to just go to my computer.
     
  8. macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #8
    yeah i heard it doesnt work with WPA, but it works fine with my WPA2 router.
     
  9. macrumors member

    Joined:
    Feb 19, 2008
    #9
    My ipod touch 2G has a real hard time connecting to wifi networks. It says its connected under Settings but it lies to me. Even when I let it sit and think about it, it will sometimes randomly connect...this happens regardless of network type, WEP, WPA, WPA2, and unsecure. Any ideas if there is something I'm doing wrong or maybe a fix?
     
  10. macrumors regular

    Joined:
    Dec 18, 2006
    #10

    Strange, as I can't connect via WEP at work. It'll ask for the password, but it won't connect. This might be because our network is WEP Hex... don't know.

    Are you using WEP Hex encription? Does the iPod Touch support WEP Hex encription?

    BTW... I just tried connecting at home via WPA and was successful.
     
  11. macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #11
    A few of us are in the same boat. I don't even have WEP, just MAC filtering on my router. I haven't tried restoring my Touch or anything like that yet.

    I'm hoping 2.2 solves this problem. I really like the 2G for the speaker and volume buttons, but the wifi thing is a pain.
     
  12. macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #12
    Okay, one thing I've noticed is that the wifi on my 16GB 2G works a LOT better if I take the rubber case off. The case is a XtremeMac Tuffwrap that I used previously with my 1G Touch (which had great wifi.)

    It's still somewhat flaky, but will now connect more often than not, though not from as far a range as with my 1G.
     

Share This Page