1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Can't get wireless adapter working on new 2013 MacBook Air in Windows 8

Discussion in 'MacBook Air' started by JollyJoeJoe, Aug 3, 2013.

  1. macrumors regular

    #1
    Windows 8 installed fine through EFI Boot. I ran bootcamp and installed all the drivers etc. The broadcom adapter is detected and installed fine, however the connection established to the wi-fi router is flagged as limited with a question mark and the internet does not work.

    Tried un-installting from device manager and re-installing bootcamp. Didn't help. Wireless adapter works fine in OSX. Using latest bootcamp drivers as downloaded by the assistant today.
     
  2. macrumors 65816

    #2
    Did you see this thread, front page of this forum, 12 threads down from yours?
     
  3. macrumors regular

    #3
    Doesn't have much in common with my problem. The op actually manages to establish a working connection and when their problem arises they don't see any available wireless networks to join. I on the other hand see all the wi-fi networks all the time, but when I join it's flagged as limited and the internet does not work.
     
  4. macrumors 65816

    #4
    I don't know what I was thinking. Two people with a 2013 MBA, Windows8 and WiFi problems. Yep, you're right, nothing in common.
     
  5. macrumors regular

    #5
    Yes, because all wi-fi problems should be binned together.
     

Share This Page