Can't hide Windows icon from OS X Desktop

Discussion in 'Windows, Linux & Others on the Mac' started by ToastMaster, Jan 16, 2007.

  1. ToastMaster macrumors regular

    ToastMaster

    Joined:
    Nov 10, 2005
    Location:
    Tacoma, WA
    #1
    So I installed windows XP via Boot Camp on my MBP in FAT32, and can't figure out how to hide my XP icon from my desktop on OSX. I know that the easiest way to do it is rename the HD in Windows to something like ".Windows" (I've done it before on a previous partition), but for some reason it's not letting me do it this time. It just gives me the error message "the label is too long, or contains invalid characters.

    I was able to rename it in NTFS, does that have something to do with it?
     
  2. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #2
    Yes. Mac OS X cannot write to NTFS. You must rename it in Windows.

    Of course, you could always turn off displaying of hard drive icons in the Finder preferences, too.
     
  3. ToastMaster thread starter macrumors regular

    ToastMaster

    Joined:
    Nov 10, 2005
    Location:
    Tacoma, WA
    #3
    No, you misunderstand.. I'm using FAT32, and I can't seem to rename it to ".Windows" in Windows without getting some error message. I used NTFS before with no problems doing this (which I thought was kind of weird.)
     
  4. Ike macrumors newbie

    Joined:
    Oct 11, 2006
  5. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #5
    I think . might be an illegal character in FAT32
     
  6. hopejr macrumors 6502

    Joined:
    Nov 10, 2005
    Location:
    New South Wales, Australia
    #6
    Yes, you cannot have periods in disk labels on FAT32. IIRC from back in my old DOS days, FAT partitions can only have volume labels of 11 characters long that are alphanumeric and allow underscores.
     
  7. Glen Quagmire macrumors 6502a

    Joined:
    Jan 6, 2006
    Location:
    UK
    #7
    The easiest way to hide your XP drives is to tell OS X not to mount them.

    Start Terminal.
    Type:

    Code:
    sudo -w /etc/fstab
    
    Type your password at the prompt and press RETURN. This will start nano, a Un*x editor.

    For each drive you want to hide, type the following:

    Code:
    LABEL=<<drive name>> none ntfs ro,noauto 0 0
    
    Replace "<<drive name>>" with the name of the volume you want to hide. If your drive is called "Windows", for example:

    Code:
    LABEL=Windows none ntfs ro,noauto 0 0
    
    Make sure you type this in exactly as shown - spaces are important.

    Press CTRL+O to save.
    Make sure it says "/etc/fstab" and press RETURN.
    Press CTRL+X to exit nano.
    Quit Terminal.
    Reboot.

    If you want to mount the drive at any time, you can do so via Disk Utility.
     
  8. hotboiled macrumors member

    Joined:
    Oct 30, 2006
    #8
    sudo -w /etc/fstab

    =

    sudo: illegal option `-w'
    usage: sudo -K | -L | -V | -h | -k | -l | -v
    usage: sudo [-HPSb] [-p prompt] [-u username|#uid]
    { -e file [...] | -i | -s | <command> }
     
  9. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #9
    Try
    Code:
    sudo [B]nano [/B]-w /etc/fstab
    The -w means don't wrap lines.

    B
     
  10. macwhack macrumors member

    Joined:
    Aug 31, 2006
    #10
    isnt there any other way .
    I just want to hide my windows xp harddisk icon and not dismount it on startup.
     
  11. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #11
    If NTFS, rename it as mentioned earlier in the thread. boot to XP, rename to ".Windows", boot back to OS X. If FAT32, you're out of luck.

    B
     
  12. Archmagination macrumors regular

    Joined:
    Dec 15, 2004
    #12
    Is there anyway to undue the: sudo nano -w /etc/fstab ?
    It didn't work for me and it seems to be slowing my computer down on Startup now.
     
  13. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #13
    Run sudo nano -w /etc/fstab again and undo the changes you made to the file.

    Side note. Always a good idea to back up a file before you modify it. Should have been mentioned in the instructions above.

    B
     
  14. jhelm85 macrumors newbie

    Joined:
    Jul 7, 2008
    #14
    Also note that if your windows partition is fat32, you should replace ntfs with msdos

    source: http://www.macosxhints.com/article.php?story=20060930150059172
    source: man fstab
     

Share This Page