Can't load app on iPhone 3.0

Discussion in 'iOS Programming' started by Vonswanko, Apr 14, 2009.

  1. macrumors regular

    Oct 18, 2008
    I am new to the developing arena, and am trying to load my first app on my phone for testing.

    I have made my provisioning profile, put it on my test phone, build for device, and keep getting the following error

    error: can't exec '/usr/bin/codesign' (No such file or directory)

    I have searched for the file, and searched for help. Anyone else with this problem?
  2. macrumors member

    Apr 7, 2009
  3. thread starter macrumors regular

    Oct 18, 2008
  4. macrumors demi-god


    Oct 16, 2006
    Make sure that it is trying to debug in 3.0, The latest beta will not do anything less.
  5. macrumors demi-god


    Apr 10, 2006
    Ellicott City, MD
    If your target is set to 2.x it won't work, it's in the beta 3 notes as a known bug.
  6. thread starter macrumors regular

    Oct 18, 2008
    Hey thanks for the help. I have the target set to Device 3.0 debug, and still get the error. I looked for the exec file in developer/usr/bin but nothing is in there. I'm at a dead end with this. I posted the same topic on the ADC iPhone forums also.
  7. macrumors newbie

    Apr 16, 2009
    by any chance were u using the beta 3 or 2 for this? I seem to be having similar problems.
  8. thread starter macrumors regular

    Oct 18, 2008
    I have been using all the betas. Apple Dev helped me sort things out. Seems the file was there, but had been renamed some how. It went from codesign to codesign.orginal. I ran terminal to rename and viola, can now build and install on my device.

Share This Page