Can't play/download purchased or rented movies?

Discussion in 'Mac Basics and Help' started by AppleMint, Jan 15, 2013.

  1. macrumors newbie

    Joined:
    Jan 15, 2013
    #1
    Hello all. I've had a problem for quite some time that I never solved. For some reason my Mac and iTunes has never worked right with movies.

    If I were to rent one for example, the download bar changes to the familiar rotating candy-cane effect almost immediately, and then I a told to click to being watching the movie already.

    Of course this doesn't work, and waiting for a lifetime has no effect.

    I am curious if anyone were to know the exact problem here, I have tried everything and this one seems to beat me. A search on the net does not seem to bring this particular case up. I have already changed my ISP and that was no help. Everything is up to date.
     
  2. macrumors 603

    justperry

    #2
    Did you ever try this out in a different User Account, if you don't have another User Account make one in Users And Groups and then log into that Account, if everything works there this points towards your normal User Account having issues, if it does not work either then the problem is system wide.
     
  3. thread starter macrumors newbie

    Joined:
    Jan 15, 2013
    #3
    Thanks Just, I did try that as well after other things failed, and I had the same problem. This just totally stumps me. If I use another computer on the network then there are no problems. After moving to another location the issue still exists.
     
  4. macrumors 603

    justperry

    #4
    This is OS related and since it also happens on the other Account it's System wide, which means it is not in your Home Folder nor in other Users Home Folder.
    There could be things inside the main Library Folder.

    Do you have anything in:

    /Library/LaunchAgents
    /Library/LaunchDaemons
    /Library/StartupItems

    If you don't see the Library do this:

    In Finder click on Go-Go To Folder... or Command-Shift-G, a pop up window appears and type /Library
     

Share This Page