Can't print to Windows printer

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Nermal, Nov 16, 2003.

  1. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #1
    I have a printer attached to my Windows machine, and with Jaguar I had to make PDFs of everything I wanted to print, then send them over to the other computer and print from there.Then I heard that Panther can print over a network to a Windows computer. So now I've got Panther, and can't get printing to work.

    I go into the Printer Setup Utility and find the printer. That's fine. But then it asks me what model of printer I have, and the one I have (HP DeskJet 710C) is not in the list. I've tried Generic, but that didn't seem to work. I also tried selecting "Other", but that just dropped me into a file selector :confused:

    Why does the Mac even need to know what model it is? The printing's happening on the Windows side. How do I make my printer work?
     
  2. mklos macrumors 68000

    mklos

    Joined:
    Dec 4, 2002
    Location:
    My house!
    #2
    When you did the Panther upgrade did you install the Gimp-Print drivers? If so then I would just use the HP Deskjet 970 series Gimp Print Drivers.

    Make sure that you have the printer shared on the Windoze side. When you go to add the printer on the Mac side select Windows Printing and see if either your PC or your printer shows up. If not then look below...

    You will also need to make sure that the Mac is looking for the correct "Workgroup". Look on the Windows side (Rt. click on My Computer/Properties) and see what the workgroup name for it is. I believe by default its called Workgroup. Once you know what it is, go to Directory Access (Applications/Utilities) on the Mac side and then click on SMB, then click on the configure button (you may need to authenticate with Admin. password). There, make sure that the workgroup name matches the name in that box. If not then type in the name of the correct workgroup.

    This can take some playing around to get it working. If you have any other problems just post them here and someone will help!
     
  3. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    Yes, I have the Gimp Print drivers installed. I tried selecting the HP 970 (900 Series actually) but it didn't work. As soon as I go to print, it just says that there are no print jobs.

    The printer is shared properly, I can print to it from other Windows boxen. I've just changed the workgroup name in Directory Access, but it had no effect.

    Any more ideas?
     
  4. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4

Share This Page