Can't read FireWire HD

Discussion in 'Mac Basics and Help' started by CrEsTo, Sep 30, 2006.

  1. CrEsTo macrumors 6502

    CrEsTo

    Joined:
    Jun 23, 2006
    Location:
    Australia
    #1
    Somehow I managed to change the permissons of an external HD. It is mounting but I cannot see it in the finder, and can't repair permissions via Disk Utility.

    How can I fix the problem?

    The HD is located in

    /Volumes/OWC HD
     
  2. frankblundt macrumors 65816

    frankblundt

    Joined:
    Sep 19, 2005
    Location:
    South of the border
    #2
    you can see it in Volumes? Does it show the contents? (in which case can you Get Info on it and change the permissions there?) or is it just a dead alias (in which case turn off the external, delete the alias or if it won't let you, reboot and then delete it, and then turn on the external)
     
  3. CrEsTo thread starter macrumors 6502

    CrEsTo

    Joined:
    Jun 23, 2006
    Location:
    Australia
    #3
    I can see the HD mounted on Terminal and Disk Utility, but not with the finder.

    When I do an "Info" on Disk Utility it says:

    Owners Enabled : No
    Can Turn Owners Off : Yes

    But there's nothing to change there... I was trying to find a way to change the permissions via Terminal, it currently has:

    (d---r-xr-x 10 marcoaki marcoaki 442 Sep 30 15:23 OWC HD)

    but I can't figure out the correct command.
     
  4. frankblundt macrumors 65816

    frankblundt

    Joined:
    Sep 19, 2005
    Location:
    South of the border
    #4
    If you use Finder > Go menu > Go to Folder... > /Volumes
    do you see the alias for the External there? If so you should be able to do a Get Info (Apple-I) on it. I'm not too hot on Terminal sorry.
     
  5. CrEsTo thread starter macrumors 6502

    CrEsTo

    Joined:
    Jun 23, 2006
    Location:
    Australia
    #5
    Restarted and now I can see it, however I cannot delete the alias or modify the permissions. It says I don't have sufficient privileges to delete the alias.
     
  6. frankblundt macrumors 65816

    frankblundt

    Joined:
    Sep 19, 2005
    Location:
    South of the border
    #6
    did you restart with the external disconnected? - that normally "frees" the alias so that you can delete it and then try remounting. If the external is still on/connected, can you Get Info on the alias in /Volumes ? Will it let you change the Owner there (you normally have to click the lock symbol and authenticate with an admin username/password)
     
  7. excellentbadger macrumors newbie

    Joined:
    Jan 25, 2008
    #7
    similar issue

    Sorry to bump up an old thread, Just didn't think this was worth starting a new one.

    I'm currently having a very similar problem, I have somehow changed the permissions on an external firewire HD and it won't show up in finder anymore. I have tried doing what people have suggested here, however no matter what I do I can't delete the Alias.

    If i disconnect the hard drive, it doesn't appear in the /volumes folder allowing me to delete the alias, and if i leave it connected I'm told I don't have permission to delete the alias. I've tried restarting and all.

    Can anyone help? I would be so grateful as the hard drive has all my uni coursework on it!

    Andy
     
  8. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #8
    Open new window, keep going up (Keyboard COMMAND-UpArrow) until you see drive, get info, check "ignore permission on this volume".
     
  9. excellentbadger macrumors newbie

    Joined:
    Jan 25, 2008
    #9
    Thanks for your reply,

    do you mean up in the finder window? when I do that, it shows my main HD and a network icon, but the external icon isn't there for me to do anything to..
     

Share This Page