Can't send mail with mac mail

Discussion in 'Mac Basics and Help' started by Littleboo, Jun 4, 2009.

  1. macrumors regular

    Joined:
    Jul 23, 2008
    #1
    All of a sudden I cannot send mail from my main Mac. My other 2 work fine so I know it's program issue.

    I called my internet provider and they told me i had to contact Apple so I thought I'd start here.

    She did suggest that I delete my mail account and set it back up. I'm willing to try this, but I can't loose all my mail. So, I have a back up on time machine if I need it, but I'm not sure how to re enter it into mail.

    thanks
     
  2. macrumors 6502

    thunderweb

    Joined:
    Oct 22, 2008
    Location:
    Bend OR
    #2
    Go to Finder, click on the Library folder under your user account, find the Mail folder, click on whichever account your deleting and copy the mbox to your desktop. Then go into Mail and delete the account. Then select file and click on Import Mailboxes. Select mbox and find the files and import them. Once you've done that select Mailbox in the menu bar and click Archive Mailbox. That should do it for ya. Make sure you copy over all your folder mboxes and your account mboxes. For example I marked my Mail accounts blue and my folders green. I hope that makes sense. Good luck!
     

    Attached Files:

  3. thread starter macrumors regular

    Joined:
    Jul 23, 2008
    #3
    I tried to import, but couldn't. Said no valid files. I entered a new account in but it did not solve the issue. Any other thoughts on what could work?
     
  4. macrumors 6502

    thunderweb

    Joined:
    Oct 22, 2008
    Location:
    Bend OR
    #4
    Have you tried to reinstall Mail with your install discs?
     
  5. thread starter macrumors regular

    Joined:
    Jul 23, 2008
    #5
    good Idea. I don't know how.
     
  6. macrumors 6502

    thunderweb

    Joined:
    Oct 22, 2008
    Location:
    Bend OR
    #6
    It's a little complicated but download Pacifist . It allows you to install individual apps from the OS X install disks. You pretty much just put the disk in and open that app. If you need further instruction just ask but I think you should be able to figure it out :)
     
  7. thread starter macrumors regular

    Joined:
    Jul 23, 2008
    #7
    So, I believe I did it right. I deleted the mail from applications, then I downloaded Pacifist and dragged the mail icon to the harddrive application folder. it extracted and when I opened it and went to import the mbox files I get an error: No valid mbox files were found. I also tried to put the folder back into Library folder, but that account is not showing up.
     
  8. macrumors 6502

    thunderweb

    Joined:
    Oct 22, 2008
    Location:
    Bend OR
    #8
    I had that problem once as well, I think I wrote down how to fix it but lemme check...
     
  9. macrumors 6502

    thunderweb

    Joined:
    Oct 22, 2008
    Location:
    Bend OR
    #9
    Make sure you are selecting the folder that contains the mbox files and not the mbox file itself. Also you should do a Repair Permissions through Disk Utility.
     
  10. macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #10
    Duff-Man says...if the repair permissions does not help, you may want to try creating another user account on the computer (it's handy to have one for testing and troubleshooting like this anyway) and creating your mail account there. If it works then then the problem is not with the Mail app itself but with something in *your* user account, perhaps as simple as the preference file being corrupted in some way....oh yeah!
     
  11. thread starter macrumors regular

    Joined:
    Jul 23, 2008
    #11
    verify/repair didn't work. I made a new account and that account can send mail, so then it must be a preference? what do I do?
     
  12. thread starter macrumors regular

    Joined:
    Jul 23, 2008
    #12
    I tried to remove all plist files and rebooted but nothing.
     

Share This Page