Can't send MMS on Verizon iPhone 5

Discussion in 'iPhone' started by acousticbiker, Sep 27, 2012.

  1. macrumors 6502

    Joined:
    Jun 28, 2008
    #1
    iMessages (text & pics) are working fine, but standard MMS to a non-iPhone user on a different carrier is not going through. I've tried toggling MMS on/off, using WiFi & LTE, power cycling, and resetting but with no success. Verizon tech support has escalated the issue, but I was curious whether anyone else was having this issue (and whether you know of a solution).
     
  2. macrumors 6502a

    Buckeyestar

    Joined:
    Sep 17, 2011
    #2
    Don't know what to tell you. I've sent pictures to both of my parent's Tracfones without any problems.
     
  3. macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #3
    So you're saying that you can send MMS fine to iMessage and other Verizon customers, right?

    If you are unable to send any MMS to any non-Verizon customer, your best bet is to contact Verizon directly.

    Sounds like a carrier issue since the phone is sending properly.
     
  4. thread starter macrumors 6502

    Joined:
    Jun 28, 2008
    #4
    Pictures going out fine through iMessage (blue), but not through MMS (green). Verizon is working on it but thought I'd check here just in case. Not sure if it's related, but my Visual Voicemail doesn't work either.
     
  5. macrumors 6502a

    Joined:
    Oct 10, 2011
    Location:
    North Carolina
    #5
    Huh both my MMS and my visual voicemail are working fine for me. Although last time I sent an MMS it failed the first time I tried.
     
  6. Big Ern, Sep 27, 2012
    Last edited: Sep 27, 2012

    macrumors newbie

    Joined:
    Sep 27, 2012
    #6
    I had a similar issue with my iPhone 5. I could receive MMS messages fine but couldn't send. I had ported my number over from Sprint and restored my phone from a backup of a jailbroken unlocked iPhone I was using on T-mobile's service. I spent about an hour with verizon customer support and tried all of their ideas but nothing worked. I finally tried resetting network settings which did nothing. The solution for me ended up being erasing all data and settings on the phone under the Settings->General->Reset->Erase All Content and Settings and setting it up as a new phone. Then my MMS messages would go through instead of hanging at the end and saying "Not delivered."

    This may also work with choosing reset all settings instead.
     
  7. thread starter macrumors 6502

    Joined:
    Jun 28, 2008
    #7
    Ugh...I was afraid that might be the solution (I restored from a non-Verizon iPhone). Thanks for taking the time to share
     
  8. macrumors newbie

    Joined:
    Sep 27, 2012
    #8
    Yea I wasn't thrilled about it either. I had to manually replace all the pictures on my camera roll which took a long time and redo all of my custom ringers. I also lost the notes in the notes app I had saved and my prior text message threads. I didn't want to do it but Verizon support basically wouldn't do anything else for me until I reset the whole phone. Some people with similar issues have said that it is a carrier issue that can be changed on their end. When I talked to them they couldn't even see that I was trying to send the messages so they weren't even making it off my phone.
     
  9. thread starter macrumors 6502

    Joined:
    Jun 28, 2008
    #9
    Just got off with VZW support and the suggested 'Erase all settings' (not content), which fixed the MMS problem but not visual VM. Had to redo all my settings but not as bad as reloading all content! Now if I can just get VVM to work!
     
  10. macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #10
    I know way back when, I had to have AT&T enable my visual voice mail separately. So it might be on Verizons end. But it seems that your'e able to send MMS over data, but not cellular. Which is again on Verizon.
    Would be interested in the resolution.
     
  11. thread starter macrumors 6502

    Joined:
    Jun 28, 2008
    #11
    Hey all, forum user 'Arbagel' pointed out this solution to me:

    http://www.fredmckinnon.com/myblog/2012/07/05/verizon-iphone-text-mms-and-visual-voicemail-mystery-solved/

    This fixed my VVM problem and probably would have saved me from a 'Reset All Settings' operation to revive my MMS functionality
     
  12. macrumors newbie

    Joined:
    Sep 17, 2012
  13. macrumors regular

    Joined:
    Mar 30, 2009
    #13
    didn't work for iPhone 5 with at&t
     
  14. macrumors newbie

    Joined:
    Sep 17, 2012
    #14
    any luck with this? i have the same issue
     
  15. macrumors 6502

    Joined:
    Mar 10, 2012
    #15
    You don't have the Onavo data saving app installed by chance, do you? I downloaded it and had the same problem. I deleted it and my mms started working again.
     
  16. thread starter macrumors 6502

    Joined:
    Jun 28, 2008
    #16
    Thanks - yes, that is what I was referring to in my post (#11) above.

    ----------

    Yes, please see post #9 & #11 for two different options
     
  17. macrumors newbie

    Joined:
    Sep 17, 2012
    #17
    Verizon called me back i had to delete my msg threads and gointo my contacts delete any of them that did not have the area code in the number and re enter them, it didnt work unless the msg thread from that person was erased first.
     
  18. macrumors newbie

    Joined:
    Nov 22, 2012
    #18
    This Is what I had to do as well, since verizon customer services didnt help at all, but it worked. Trying to remember all my settings was the hard part.
     

Share This Page