Can't start up new Mac Mini 2011 with Lion

Discussion in 'Mac OS X 10.7 Lion' started by Victor P., Sep 13, 2011.

  1. macrumors newbie

    Hi everyone.

    I'm in some trouble.
    I've just got a new mac mini 2011 and tried to bootcamp a windows partition but I couldn't make it right so I delete it and get back to a all mac partition, then, after some restarts I couldn't get out of the screen with the apple logo and the loading, it was just stuck forever in there, so I've searched on the web and found a solution, booting with cmd+s and some codes on the terminal, like chmod o+r, chmod o+x, then everything was all right.

    But, today when I tried to start my mac mini it get stuck on the apple logo loading and then appears a stop-sign, so I restarted with the cmd+s and in the terminal appears this message:

    hfs_mount root failed = 5
    cannot mount root, errno = 19

    What is going on?
    Anyone knows some solution for this?

    Also, I could make a clean reinstall but how am I supposed to do that if the mac mini 2011 doesn't comes with cd drive and some usb install, should I download Lion and make a bootable usb? But then my Lion wouldn't be original anymore?

    Well, I really need some help =/
    Thanks already.
  2. macrumors regular

    First try booting with command-R, run disk utility, repair disk, repair permissions. If that command-R doesn't work do a option-command-R and you will boot from the Internet.

    You can then install Lion directly from the Internet if needed.
  3. macrumors newbie

    All right!
    The repair disk and permissions worked nicely!

    Thanks! :D
  4. macrumors newbie

    Well, not so much

    Now everytime I restart I've to keep the "x" key pressed or do the repair again.

    Why is that? What can I do?

    Thank you.
  5. macrumors G5


    I Assume

    You have your original SL DVD? Backup all your critical data to an external drive, double check that you have it all (Don't use time machine for this backup just drag the folders "as is" to the drive.)

    Perform a clean install of SL by booting withe the DVD in the drive.

    Then try the Lion install again. If it fails again, I'd be suspecting a faulty HDD
  6. macrumors member


    Are you using disk utility for the same? I would suggest try any other third parry software for the same purpose sometimes disk utility fails to rebuilt the drive. else take a backup or prepare clone of all of the data you have and re initialize the drive with HFS or HFS+ file system. For all above purpose you can use any other trusted utilities or you can use single utility called Mac drive toolbox for all above purpose. And then re install the os x lion once again either clean install or using Apple ID.
  7. macrumors G5


    Good Advice

    You could also try repairing the volume with the Onyx app (Just Google it) it's in BETA, but I find it faster and more thorough than Disk Utility.
  8. macrumors newbie

    More problems now..
    My password just doesn't work, so I can't install those disk repair softwares, when I'm going to install it asks my password, I type it and press enter and the window just vanish and nothing happens, the same thing for the system preferences, nothing changes..

    Looks like I've messed up really bad the permissions and diks settings, I already tried to reinstall Lion, but the simple reinstall by the Recovery HD (command+r) just reinstall and didn't format my hd, so the errors keep happening
    How can I restart everything from the start?
    If I do the internet recovery will erase everything? Or should I erase all the hd with the disk utility and install again?

    I don't care if I lost everything (its new, there's almost nothing), I just don't want all those issues happening anymore.

    Also, I'm afraid to erase all the hd and then asks the password and doesn't work, then I'll have no hd and a password that doesn't work for install..

    Any ideias and suggestions?

    Thank you.
  9. macrumors member


    In that case you have no option than to erase the drive. :( and that also only with the help of disk utility! Don't worry erase using disk utility would not require any password. But make sure whole data of the drive will be lost. After erasing initialize the drive with HFS+ (journaled) file system,

Share This Page