Can't turn Bluetooth off

Discussion in 'macOS' started by croshtique, Nov 12, 2005.

  1. croshtique macrumors 6502

    Joined:
    Apr 28, 2005
    Location:
    Cambridge, UK
    #1
    OK, so this is more of a niggle than a real problem but it's curious. Basically I no longer have the ability to turn Bluetooth off on my iBook, in the menu or in system prefs (see attached screenshots). I'm using a D-Link DBT-120 adapter so it's not a big deal (I can just unplug the thing!) Have repaired permissions, restarted, and it wasn't a problem after installing 10.4.3 - this has just developed in the last few days. Any thoughts?
     

    Attached Files:

  2. DXoverDY macrumors 6502a

    Joined:
    Apr 19, 2005
    #2
    that particular device probably doesn't let you turn it off. that's why.
     
  3. croshtique thread starter macrumors 6502

    Joined:
    Apr 28, 2005
    Location:
    Cambridge, UK
    #3
    Nope - I've had this adapter for over a year and have been happily turning it on and off until a few days ago...
     
  4. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #4
    did you have a device connected when you were able to turn it off before? perhaps? just taking a random guess here....
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    Try spotlighting and deleting the plist associated with it... probably "com.apple.bluetooth.plist" but maybe something else, since you have a 3rd-party adapter. You can move it to the desktop while the device is NOT inserted, and then plug the device in, just to make sure you don't lose anything valuable. You might have to re-pair devices.
     
  6. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #6
    Funny, the same thing happened to my Mac (10.4.3). I had to go into the Bluetooth File Exchange utility to turn Bluetooth back on. Once I did that, I could turn the bluetooth adapter off and on normally.

    This is with a built in adapter.
     
  7. croshtique thread starter macrumors 6502

    Joined:
    Apr 28, 2005
    Location:
    Cambridge, UK
    #7
    Aha, that fixed it - thanks!
     
  8. DarkNetworks macrumors 68000

    DarkNetworks

    Joined:
    Apr 12, 2005
    #8
    i've tis DLINK DBT-122 which's a bluetooth adapter(USB) it doesn't have the off thing or anything...is it okay for me to just plug it out after using it or wht...it has a power light, am i damaging the thing? i can't find anything that can be done or any buttons to Off it...including the top one where u have an option of offing it on the taskbar but mine's don't have one...i tried BlueTooth File Exchange but there's no settings that i can change there..
     
  9. Voidness macrumors 6502a

    Voidness

    Joined:
    Aug 2, 2005
    Location:
    Null
    #9
    I have the same problem right now. I just noticed it when I tried to connect my Apple Wireless Mouse to my iBook (10.4.3, built-in adaptor). I couldn't connect my mouse to the iBook, so I wanted to try to turn bluetooth off and back on again, to find that I can't turn it off! I tried deleting the plist files and it didn't work. I also tried the bluetooth file exchange with no luck :(

    Any suggestions?

    EDIT: I got it working again, it seems there's some kind of glitch in 10.4.3
     
  10. Jay42 macrumors 65816

    Jay42

    Joined:
    Jul 14, 2005
    #10
    Wow, very weird. I saw this thread recently and didn't pay much attention. Now I too have the same problem on 10.4.3. Not sure what to do. BTW, I have bluetooth built in to my PowerBook, but have yet to use it and I don't have an ext. adapter.
     
  11. .:*Robot Boy*:. macrumors 6502

    Joined:
    Jan 21, 2005
    Location:
    New Zealand
    #11
    This happened to me after every OS X 'point' update on my PowerBook with built-in Bluetooth. A restart or two usually fixed it.
     
  12. Jay42 macrumors 65816

    Jay42

    Joined:
    Jul 14, 2005
    #12
    Yup, restart did the trick. Seemed to start randomly though, not after an update:confused:

    EDIT: Ha! I was able to recreate the problem! Seems to happen after I try the Safe Sleep (hibernation) hack on my powerbook. Link To Safe Sleep Hack
     

Share This Page