Can't turn on Personal Web Sharing

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Owaho, May 3, 2004.

  1. Owaho macrumors newbie

    Joined:
    Nov 4, 2003
    #1
    I'm trying to turn on personal web sharing but it won't turn on. When i click start in the sharing preferences it just displays "starting" and does not move on. If i close network preferences and go back into sharing, nothing is happening at all. Personal Web Sharing doesn't even have a check mark next to it. help?!?!

    edit: i changed my personal web sharing port to 427 and it started working- will this affect anything else?? do i need to change anything else? also when i go the the address listed or 127.0.0.1/~username/ a video/quicktime Object shows up with "404: not found" as the title. how can i fix this?
     
  2. MoparShaha macrumors 68000

    MoparShaha

    Joined:
    May 15, 2003
    Location:
    San Francisco
    #2
    Try 127.0.0.1:427/~username/ a video/quicktime. The default port for webservers is 80, so it is always omitted from URLs. If you change the port however, you need to show it in the URL with a colon, as shown above.
     
  3. Owaho thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #3
    thanks so much!

    i'd still like to know if there is a reason personal web sharing won't start on certain ports? it wasn't working on 427 so i switched to 433 and it all works now. but why can't i turn sharing on through port 80 and port 427? thanks!


    sudeep
     
  4. Durer macrumors newbie

    Joined:
    Apr 24, 2004
    #4
    Me Too! after configuring Apache httpd.conf enabled php, it wount start the pws.
    does anyone know this
     
  5. LeeTom macrumors 68000

    LeeTom

    Joined:
    May 31, 2004
    #5
    If apache finds an error in its httpd.conf file, or any files that it includes, it refuses to start. Have you messed with this file?

    Lee Tom
     
  6. sonofslim macrumors 6502a

    sonofslim

    Joined:
    Jun 6, 2003
    #6
    port 427 is, by default, used by web sharing and file sharing in addition to 80 -- look under the Firewall tab in your Sharing preferences.

    the fact that you get the "Starting..." message, but no completion, sounds to me like you've got some error in your httpd.conf file, as LeeTom suggested. but if you can get it working on other ports, maybe not. i'm just guessing here, but maybe you've got some conflict with your internal firewall. have you changed any of those settings?
     

Share This Page