Can't turn sharing off. Virus ?

Discussion in 'macOS' started by Carlitoz, Feb 23, 2006.

  1. Carlitoz macrumors newbie

    Joined:
    Feb 23, 2006
    #1
    Poster on Apple forums but want to know if anyone here already had the same problem:

    After browsing and doing several regular thing in my mac. Some sharing preferences turned on and i can't turn them off (Widows sharing, Remote Login, FTP Access, Remote Apple events).

    It sounds a bit suspicious for me. And i hope it's not some kind of virus. It doesn't sound like the one people talked about this week.

    Any one have any thoughts on it ? Any one having the same problem ?

    Thanks.
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Have you tried restarting? It could be that the daemon processes are "stuck" so cannot be stopped.
     
  3. croshtique macrumors 6502

    Joined:
    Apr 28, 2005
    Location:
    Cambridge, UK
    #3
    In what way can't you turn them off? Are the options greyed out in System Prefs > Sharing > Services or something?
     
  4. munkees macrumors 65816

    munkees

    Joined:
    Sep 3, 2005
    Location:
    Pacific Northwest
    #4
    These open ports on your computer are very robust, but to switch them off by going to system preferences: sharing click on the lock to unlock then you can switch them off buy just click the tick boxes.

    Is your log on account your admin account aswell ?

    I putting a little keynotes for people to harden they make, it small changes but make them alot more secure, I will post it in the next 12 hours.
     
  5. pseudobrit macrumors 68040

    pseudobrit

    Joined:
    Jul 23, 2002
    Location:
    Jobs' Spare Liver Jar
    #5
    Not unless you installed Windows.

    You're going to have to be way more specific about what you're doing and how you're logged in.
     
  6. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #6
    You change these values on this preferences screen...
    Picture 6.png

    If as in the picture the lock in the left hand corner is locked (as in my picture) then you need to click on it and type your admin password to unlock...

    You cannot change these settings on the firewall tab...

    When I first got my iMac I had a suspicious issue where when i clicked to switch off Windows Sharing it would go back after about a second.. since then I've made sure I have a unique password for my Mac and in the Security Preferences pane I have checked the box saying "Require Password to Unlock each Preferences pane", I still have my computer to auto-login (in the login preferences pane) so locally I don't need to type in my admin password each time I switch on my Mac...

    (btw you should switch on the Firewall if its not already)

    If you are looking at the sharing tab (as in the screenshot) in the Sharing preferences pane, and the padlock is unlocked then I'd say your computer has been hacked :(, this happened many times on my PC with Norton Internet Security (the solution i found was to stick a secure unique password on the settings for it...),

    The solution is probably unfortunatly to re-install the software, in this case Mac OS X... this isn't actually very painful as you insert the CD, choose Archive and Install and come back about an hour later, your computer will be set up as before though! (unlike Windows), a few apps eg. Virus Barrier X need reinstalling after doing this though... and you will need to run software update again and get any updates...
     
  7. munkees macrumors 65816

    munkees

    Joined:
    Sep 3, 2005
    Location:
    Pacific Northwest
    #7
  8. Carlitoz thread starter macrumors newbie

    Joined:
    Feb 23, 2006
    #8
    Hi. Guys. I appreciate alll teh help. I was away from the computer the whole so i didnt have the chance to check your messages. But all you guys told i tried already.

    The sharing option are not protected by the lock or greyed out. They are as they normally look. But when i click to switch 'em off either they hang on forever and never turn off or they do nothing. i click on it and the check box wont turn off (it evens hilite when i click).

    But yeah. so far no luck. Again, thanks for the help!
     
  9. mjstew33 macrumors 601

    mjstew33

    Joined:
    May 29, 2005
    Location:
    Illinois
    #9
    I'm not sure if someone said this, but repairing permissions might help?
     
  10. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #10
    OK if thats the case there are a couple of causes...

    #1 there is a hacker/virus/worm/trojan on your computer...

    Alternatively
    #2 Mac OS X has got corrupted on your machine

    First probably you should back up your data
    The solution to both is to re-install Mac OS X, first try an Archive and Install, this should keep your applications and documents and computer settings intact and working, this will cure #2 and probably #1 too. If you cannot switch off sharing options that is very worrying...

    With Windows I would be screaming #1, i have seen it before, basically you cannot install AntiSpy software, the Ctrl Alt Delete window disappears after about 1 second, and Norton fails to install too...

    It was a huge effort to persuade the computer owner that it was hacked and Windows needed reinstalling, but basically however bad you consider the OS to be the chances are its not an accident...

    if Archive and Install doesn't solve the problem then certainly backup your data as otherwise it will be lost and reinstall again using an Erase and Install.

    EDIT

    Try repairing permissions first, it might solve it, it might just be the system can't write to the preferences file, you do this with Disk Utility...
     

Share This Page