Can't update iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by apup102, May 29, 2011.

  1. macrumors newbie

    Joined:
    May 13, 2011
    Location:
    Seattle
    #1
    I'm trying to update my iPhone to 4.3.3, but I keep getting this message:
    "The iPhone could not be updated. This device isn't eligible for the requested build."
    I have an iPhone 4, 32GB, GSM model. I have tons of space left on it. The update says that it supports iPhone 4 GSM. I don't understand. Help?
     
  2. macrumors newbie

    GADeputy

    Joined:
    May 9, 2009
    #2
  3. thread starter macrumors newbie

    Joined:
    May 13, 2011
    Location:
    Seattle
    #3
    Still didn't work. :(
     
  4. Guest

    Joined:
    Apr 10, 2008
    #4
    is your phone jailbroken?
     
  5. thread starter macrumors newbie

    Joined:
    May 13, 2011
    Location:
    Seattle
    #5
    No, it isn't.
     

Share This Page