Carrier information "Not Available" after 3.0 jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by gerfuls, Jun 19, 2009.

  1. macrumors member

    Joined:
    Jan 31, 2009
    #1
    Being all excited to get my iPhone 3G running 3.0 jailbroken, I downloaded PwnageTool 3.0 and built my custom firmware. Went into DFU without any problems, selected my custom firmware, waited....., and then when my iPhone was was finished I looked up into the top left corner only to see 1 bar of signal and no "AT&T" logo. When I went to Settings > General > About > Carrier read "Not Available." So obviously I have no cell service now. No SMS, Calls, Internet (except wifi). What did I do wrong??? My specs:

    Mac OS 10.5.7
    PwnageTool 3.0
    iPhone 3G 8GB
    iTunes 8.2

    Please help me!
     
  2. thread starter macrumors member

    Joined:
    Jan 31, 2009
    #2
    found a possible solution for anyone who may have similar issues. When creating my firmware I had been going through expert mode so i could turn off the custom boot logos and now i realize that i had left the "activate phone" option on under general which is on by default. if you turn this off it should work correctly. I'll let you know when/if i confirm the fix.
     
  3. macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #3
    Yeah, activating (well, hacktivating since it's activating the iPhone unofficially via hacks) an already activated iPhone screws things up. Restore and start over, and only choose expert mode if you're an expert ;)
     
  4. thread starter macrumors member

    Joined:
    Jan 31, 2009
    #4
    haha thanks. i thought i wouldnt have any issues with expert mode since i had used it before on 2.2.1
     
  5. thread starter macrumors member

    Joined:
    Jan 31, 2009
    #5
    anyways that was the issue and i just confirmed it was fixed through what i posted above for anyone else who was the issue
     
  6. macrumors newbie

    Joined:
    Jun 27, 2009
    #6
    Thanks for posting what you found! I did the exact same thing. The only thing I remain ticked at myself for is that I let the phone go through the entire first sync and got it all set up... only to have to do it again...
     
  7. macrumors member

    Joined:
    Oct 29, 2004
    Location:
    Carlsbad
    #7
    Thanks Forum Friends. I thought I was an expert as well. But with 3.1.2. Started to think I was going to have to reinstall with the legit 3.1.2. I'm going to give this a try.
     
  8. macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    Just be advised when updating and jailbreaking your phone to firmware 3.1 or 3.1.2 with the lower baseband (4.26.xx) the lower baseband does not correctly report the carrier info to the firmware.

    What that means is that even if you set up the IPSW correctly, there will be no carrier name in the status bar and the Settings/General/About will show not available.

    You should have service bars if you made the correct choice for activate phone, yes or no. This a cosmetic bug and does not effect the ability of the phone to make and receive cellular service.
     
  9. macrumors regular

    Joined:
    Jun 17, 2009
    #9

    I have modem firmware 04.26.08, so I guess this is the lower baseband?

    I deactivated the phone in expert mode like I was supposed to do. No carrier icon shows for AT&T. The phone works just great without this, but my question is this:

    Will AT&T assume I don't have service, or is this just the baseband reporting to the Apple firmware?
     
  10. macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #10
    It's cosmetic, just the carrier logo doesn't appear in the status bar and it says Not Available in the Settings/General/About box

    Has nothing to do with your service. It's not reporting anything to AT&T or anybody, just cosmetic.
     
  11. macrumors regular

    Joined:
    Jun 17, 2009
    #11
    I thought so. Just wanted to make sure. Thanks!
     

Share This Page