Changed the lcd/digitizer , everything work except the digitizer !!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Feel-IX, Feb 4, 2010.

  1. macrumors newbie

    Joined:
    Feb 4, 2010
    #1
    ok, so here's my story, I bought a Iphone 2g with a defective digitizer (wasn't working on the lower section of the screen) and I bought a new lcd/digitizer (cause they are sticked together as you guys probably know). I managed to disassemble the Iphone and put the new screen in. The new lcd works perfectly however the digitizer doesn't work at ALL !!!

    does anybody know which of the 4 motherboard wires is for the digitizer ?
    [​IMG]
    I tried to unplug and plug them many times though :S ...

    one of my friend told me that it might have something to do with the firmware ? that I should update it to a newer one ?

    thanks !
     
  2. macrumors regular

    Joined:
    Oct 4, 2009
    #2
    Bottom right in picture as shown. You sure it is connected properly - hard to get all connections correct on 2G? I have fixed quite a few of them and they should work fine - maybe broken in first place. Doubt if it is software. Not sure what you can do since the dig and lcd quite expensive.


    Cheers

    Spencer
     
  3. thread starter macrumors newbie

    Joined:
    Feb 4, 2010
    #3
    ok thanks! Well the lcd/digit just arrived from china (bought it on ebay, the seller had a very good rating) :confused:
     
  4. macrumors regular

    Joined:
    Oct 4, 2009
    #4
    I tried to buy from my chinese supplier buy he said that people had complained about quality. I have bought from UK buyer from ebay and had no problems. Pot luck I suppose.


    Cheers

    Spencer
     
  5. thread starter macrumors newbie

    Joined:
    Feb 4, 2010
    #5
    alright :( thanks...

    I would try to make sure that the digit wire is pluged in correctly, but yesterday while working on it, one of these wires between the motherboard and the battery accidentally broke...
    [​IMG]

    any ideas what I should do?

    I got a 15watts soldering iron, so I tried to solder it, but the "lead" that is still on the motherboard just won't melt...

    maybe 15 watts is not enough? but i'm kinda scare. Do I risk to damage the motherboard if it heats too much while trying to melt the lead?

    thanks.
     
  6. macrumors newbie

    Joined:
    Mar 4, 2010
    #6
    Hello, I got given a 2g and replaced the screen and digitizer, I have exactly the same problem, the lcd works fine but the digitizer dosent work at all. Sorry for digging up a old thread, but I would like to know if there is a reason for this?
     

Share This Page