Changing defaults for pdf in safari

Discussion in 'macOS' started by excalibur313, Jul 19, 2005.

  1. excalibur313 macrumors 6502a

    excalibur313

    Joined:
    Jun 7, 2003
    Location:
    Cambridge, MA
    #1
    On my computer when I go to pdf files it opens up in safari but on my moms it opens up in acrobat. I deleted acrobat thinking it would fix it but now it just asks where it is. Is there some place where I can change those defaults....come to think of it is there a place where I can make it so when movies are opened in safari it uses vlc instead of quicktime because quicktime tries to play all these files it can't (.asf etc).
    Thanks,
    Stephen
     
  2. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #2
    Safari or Preview?

    Anyway, try this:
    1. Select a .pdf or what ever type of file you want.
    2. Press Command+i
    3. Go to 'Open with:'
    4. Select the program you want to use
    5. Press 'Change All...'
    Done.
     
  3. excalibur313 thread starter macrumors 6502a

    excalibur313

    Joined:
    Jun 7, 2003
    Location:
    Cambridge, MA
    #3
    Nope. That will only change how it is opened on the computer not in webbrowsers. Thanks for trying though.
     
  4. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #4
    Quit Safari.

    Go to Library->Internet Plug-Ins (both in the main Library and your user Library - the plugin might be in either location).

    Find AdobePDFViewer.plugin and archive it to AdobePDFViewer.plugin.zip.

    PDFs will now open in Preview (or possibly another PDF viewer if you have one installed).

    Unzip the archive to re-use Adobe's viewer.
     
  5. excalibur313 thread starter macrumors 6502a

    excalibur313

    Joined:
    Jun 7, 2003
    Location:
    Cambridge, MA
    #5
    When I do that it just says that it cannot find the plugin I just deleted....
     
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    All you have to do is to change your QuickTime preferences to allow QuickTime to handle PDF files.
     
  7. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #7
    How do I change it so that Safari doesn't handle PDF's at all but proceeds to download it by default instead?
     

Share This Page