Chrome constantly hangs

Discussion in 'Mac Applications and Mac App Store' started by tekno, Sep 1, 2013.

  1. macrumors 6502a

    Joined:
    Oct 15, 2011
    #1
    I put in the web address, the little spinney circle goes anti-clockwise for a moment then the page goes blank, the spinney thing starts spinning clockwise... and that's it. Nothing happens.

    I can leave it for as long as I wish - it keeps looking like it's loading something but nothing happens. But the moment I refresh, the page loads immediately.

    Anyone else having this? I'm on OS X 10.7.5 with the latest Chrome.
     
  2. macrumors member

    Joined:
    Oct 1, 2009
    #2
    In the last week or so I get a blank page on every site using Chrome. I generally use FF so not bothered reinstalling it yet but something weird is going on.
     
  3. macrumors 65816

    phoenixsan

    Joined:
    Oct 19, 2012
    #3
    In my experience....

    Chrome hangs out when Flash or RAM are in trouble....Can be worth to check out that....


    :):apple:
     
  4. macrumors regular

    Thraun

    Joined:
    Dec 18, 2008
    Location:
    Abbotsford, BC
    #4
    Use Safari :D
     
  5. LPZ, Sep 9, 2013
    Last edited: Sep 9, 2013

    LPZ
    macrumors 65816

    Joined:
    Jul 11, 2006
    #5
    Been noticing this too. Try unchecking

    "Predict network actions to improve page load performance" in the Privacy Settings section of Chrome preferences (under "Show advanced settings").

    [EDIT] --- This doesn't appear to fix the problem for me, though it initially seemed promising.
     

Share This Page