Clock in Tiger

Discussion in 'macOS' started by ac2102, May 24, 2005.

  1. ac2102 macrumors member

    ac2102

    Joined:
    May 12, 2003
    Location:
    Bristol - England
    #1
    I can't for the life of me work out what on earth i am doing wrong here. I cannot get the clock on the top bar to display as i want it. i have set up the clock in Date & Time and changed the settings in the International / Formats section of System preferences. But it still can't get the clock to display AM/PM and get rid of the leading 0.

    Can anyone help?

    Many thanks in advance,
    ac2102
     
  2. Darwin macrumors 65816

    Darwin

    Joined:
    Jun 2, 2003
    Location:
    round the corner
    #2
    I had this problem awhile ago

    I fixed it through the International Settings so im not sure what could be the problem :(
     
  3. ac2102 thread starter macrumors member

    ac2102

    Joined:
    May 12, 2003
    Location:
    Bristol - England
    #3
    Thanks for the swift reply!

    Unfortunately, i have already tried that. I have attached a copy of the international setting. The clock is visible too.
     

    Attached Files:

  4. clayj macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #4
    What do the settings look like if you click the clock and then click "Open Date & Time..."? That's where you control AM/PM and whether to use 24-hour time.
     
  5. Darwin macrumors 65816

    Darwin

    Joined:
    Jun 2, 2003
    Location:
    round the corner
    #5
    yes if we can see both then it might help solve this problem :)
     
  6. ac2102 thread starter macrumors member

    ac2102

    Joined:
    May 12, 2003
    Location:
    Bristol - England
    #6
    Sorry guys! Not being particularly efficient today.

    Here is the Date & Time pref pane. The AM/PM button is greyed out.

    Thanks again for helping out!
     

    Attached Files:

  7. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #7
    Two comments that might help explain, but aren't a fix in and of themselves. In your International, notice how there is no space between the time and the AM/PM. It looks like "2:34AM" instead of "2:34 AM" -- mine looks like the latter. Also I could not find any way to make my AM/PM button in Date&Time grey out. Strange. Hate to keep asking for screenshots, but can you hit the customize button in International / Format and show us what that looks like?

    Also, possibly try changing the format back to a standard (such as US) and then re-customizing it.
     
  8. James Philp macrumors 65816

    James Philp

    Joined:
    Mar 5, 2005
    Location:
    Oxford/London
    #8
    Try toggling the 24 hour clock on/off a bit and playing around to get the am/pm thing to show.

    Personally, I don't have space on the menubar for the clock anymore, so i put one in that corner of the dashboard and just invoke that when I need to see the time. If someone asks me, it also give me a reason to use the dashboard, and they are like "Hey, what's that..."
    Hehe :D
     
  9. ZaniCWB macrumors member

    ZaniCWB

    Joined:
    Mar 16, 2004
    Location:
    Brazil
    #9
    ...

    Ok, I'll try to explain to you:

    Go to System Preferences > International > Formats

    Select 'Customize...' on 'Times' area. After that you click on the time showing. Here is 19 (then it opens a list with options > that's what you're looking for). Hope it helps.

    Posted some pics to help ;-)
     

    Attached Files:

  10. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #10
    Hmm... my AM/PM is greyed out too. And I can't force mine to get rid of the leading 0 either...

    Unless I change my region to US or US (Computer) rather than UK in International Preferences, and then it changes to 7:45PM quite happily
     
  11. ac2102 thread starter macrumors member

    ac2102

    Joined:
    May 12, 2003
    Location:
    Bristol - England
    #11
    OK, so i looked at what you were all telling me and realised that i had everything set up.

    BUT!

    I then thought about it a little more and realised that in the Customise section of Times in International/Formats i had not set all of the time formats to the same standard. That is, the short time (the one i assumed would be used for the system clock) was set up for AM/PM, not 24 hr, but the other formats were not. So when i altered all of the other formats to do the same, the problem was solved!

    Thanks so much for your help, i always try and help out when i can as i am always amazed at the willingness of members here to help out with problems, no matter how big or small.

    Thanks again,

    ac2102
     

    Attached Files:

  12. Jaffa Cake macrumors Core

    Jaffa Cake

    Joined:
    Aug 1, 2004
    Location:
    The City of Culture, Englandshire
    #12
    I also had hassles setting up the clock to my exacting tastes – you have to do a bit of fiddling around in the International/Formats/Times pane. You need to make sure the am/pm is in the horizontal bar at the top of the pane. You may have missed (I didn't realise this at first myself) that a little menu opens up when you click on the right of the 'blobs' in the bar – you can use this to remove the leading zero (I've attached a pic which shows what I mean in case I'm being a bit vague).

    Alter the options to your requirements in each of the settings (Full, Long, Medium and Short) and your clock should work as you want – at least, that's how I sorted it and hopefully it'll work for you!

    Edit: looks like ZaniCWB has sorted you out! :)
     

    Attached Files:

Share This Page