1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Combo Drive not reading discs

Discussion in 'PowerPC Macs' started by lbmontez, Jun 14, 2011.

  1. macrumors member

    #1
    My iBook G4 is refusing to read any discs. I can insert the disc, it hums like it's trying to read it, and then ejects it. It shows up in my System Profiler like it should-the drive shows to be installed and functioning, but won't read. Tried a blank disc and it does the same thing. Any ideas?
     
  2. macrumors member

    #2
    And I just tried putting a disc cleaner dvd in the drive. It accepted it, read it for a while and then went quiet. Didn't show the disc in Finder, tried opening Disc Utility and the utility refuses to load. Just shows an empty window with the beach ball swirling...
     
  3. macrumors member

    #3
    AHH...another question! Could I have to combo drive yanked from my PowerBook G4 867mhz and installed in my iBook G4? Or are they two completely different styles/sizes?

    Also, will Apple stores do this?
     

Share This Page