Compatible application for OS 9 and OS X

Discussion in 'Mac Programming' started by fzq_2000, Oct 26, 2005.

  1. macrumors newbie

    Joined:
    Oct 26, 2005
    Messages:
    1
    #1
    Hi All
    I want to write a simple application to Get and Set the Preferences of Internet browsers like Safari, IE or Netscape.
    1-Can i write an carbon application on OS X which is workable on Os 9 as well.
    2- I understand with reference to documentation that we should be writting a CFM binary in order to run on both platform OS 9 and OS X.How an we create a CFM binary from OS X ,Is it posible only through CodeWarrior or there is some way to create FM from OS X deve;opment tools (XCode etc).
    3- Which is the preferable way :
    a- Create CFM binary on OS 9 and port to OS X(How to do?)
    b- Create CFM on OS X workable on OS 9 as well(How to do?)

    Please if anybody can give me guidelines for this problem that will be of great help.Waiting for ur response experts.

    Thanks
     
  2. Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    Messages:
    7,743
    #2
    Why are you wanting to developer for OS 9? There are already apps that do this for OS 9...

    Yes you can create an application in Xcode that runs in OS 9, in Xcode. Just start a new Carbon Application.

    To developer on OS 9, you need CodeWarrior.
     
  3. macrumors 68020

    caveman_uk

    Joined:
    Feb 17, 2003
    Messages:
    2,392
    Location:
    Hitchin, Herts, UK
    #3
    Unless you have a really good reason don't bother with OS9 support. If you want to sell your stuff there's no point. The OS9 guys have pretty shown themselves to be very conservative and are unlikely to buy anything new. The earliest that's worth supporting is 10.2 though I personally wouldn't write a new app that supported anything less than 10.3.9.
     

Share This Page