Completely Disable Airplay

Discussion in 'Apple TV and Home Theater' started by kreekkrew, Sep 5, 2012.

  1. macrumors newbie

    Joined:
    Jul 17, 2011
    #1
    Hello everyone--

    I live in a college dorm, and someone else has an Apple TV. Since I've upgraded to Mountain Lion, I keep seeing the TV as an audio source for Airplay. This would be ok, except for the fact that Garageband keeps asking if I want to use it for the audio output. I have every setting I know of set to disable Airplay, but it keeps happening.

    My question: is there a way to completely disable Airplay and/or block specific devices?

    Thank you
     
  2. macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
    well you click the airplay icon and make sure its off
    if it is I'm not sure why its detecting ATVs on the network
     
  3. thread starter macrumors newbie

    Joined:
    Jul 17, 2011
    #3
    As far as I know, that only means that I'm not using airplay. It still gives me the option to use the TV, and the notifications pop up, even though mirroring is off. I'd like to just disable Airplay completely so it doesn't even look for devices, but I haven't found any options to do that.
     
  4. macrumors 6502

    Joined:
    Jun 4, 2012
    #4
    No other option unless you can somehow create or join another network. At least you can scare the hell out of them when they are using the Apple TV system by randomly playing music or air playing.
     
  5. macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #5
    is this specific for garage band? ive never had one popup asking me to airplay to my ATV
     
  6. thread starter macrumors newbie

    Joined:
    Jul 17, 2011
    #6
    The notifications are specific to Garageband, but I haven't found any options for directly turning them off. I figured it would be easier to get rid of Airplay altogether, since I never use it anyway.

    I already tried rick-rolling him, but he has a password set up on the ATV. :(
     
  7. macrumors 65816

    Risco

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #7
    http://apple.stackexchange.com/questions/43077/does-garageband-ios-1-2-support-airplay


     
  8. thread starter macrumors newbie

    Joined:
    Jul 17, 2011
    #8
  9. macrumors 65816

    Risco

    Joined:
    Jul 22, 2010
    Location:
    United Kingdom
    #9
    Oh, well I just checked Garageband on my mac and it gives an option to choose airplay under preferences audio section.
     
  10. thread starter macrumors newbie

    Joined:
    Jul 17, 2011
    #10
    I found that preference too, but again, that only asks if I want to use Airplay. Even if I decline, it still looks for devices, and a notification pops up whenever it finds a new one (said pop-up is shown below). My goal is to avoid looking for devices, so the pop-up doesn't show up whenever someone turns on an ATV.
     

    Attached Files:

  11. macrumors newbie

    Joined:
    Sep 26, 2012
    #11
    I have the exact same problem. As I move around my college campus and local coffee shops, new devices are detected all the time. It affect both Garage Band and also Hindenberg (another audio mixing program), and even interrupts the audio while I'm recording things.
     
  12. macrumors newbie

    Joined:
    May 7, 2013
    #12
    I am having the same problem. But I found this for trying to block airplay to connect. . . It seems to not be bothering me any more with garage band.

    Firewall security settings

    If you use the firewall, make sure the following firewall security options have been set to allow AirPlay Mirroring to work:

    Choose Apple menu () > System Preferences.
    Click Security & Privacy, and then click Firewall.
    Click the lock icon to unlock it if it's locked, then type an administrator name and password.
    Click Firewall Options.
    Select “Block all incoming connections” checkbox.
     
  13. macrumors newbie

    Joined:
    Dec 17, 2012
    #13
    Or, if you use multiple sharing services and you don't want to disable all of them, once in the Firewall options, you could just scroll down the list to GarageBand and only "Block incoming connections" for it.
     

Share This Page