Compressor Colors don't match FCP

Discussion in 'Digital Video' started by Benjamindaines, Jan 23, 2007.

  1. Benjamindaines macrumors 68030

    Benjamindaines

    Joined:
    Mar 24, 2005
    Location:
    A religiously oppressed state
    #1
    The first image is the footage in FCP, the second one is after it's been compressed through Compressor into a QuickTime movie.

    [​IMG]

    [​IMG]

    As you can see the colors look brighter in the QuickTime version, I want them to look just like they don in FCP (I know the image won't look as sharp because of the compression but that shouldn't change the color should it?). I corrected the color in FCP using the built in color correction filter (not the 3 way). What should I change to make this work?

    --Much thanks.
     
  2. Benjamindaines thread starter macrumors 68030

    Benjamindaines

    Joined:
    Mar 24, 2005
    Location:
    A religiously oppressed state
    #2
    Even odder is that the colors look fine in the Compressor preview.

    [​IMG]
     
  3. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #3
    Short answer Part 1: What you see in FCP is an estimation, a preview, of what the image looks like. It's not completely accurate.

    Short answer Part 2: There is not a "unified" framework in OS X to for displaying video. For example, FCP, QT, and DVD player will all handle video a bit differently and there is am issue w/unwanted gamma shifts when exporting QT's out of FCP.

    The only way to know what your video "really" looks like is to use a calibrated b'cast monitor.


    Lethal
     
  4. Benjamindaines thread starter macrumors 68030

    Benjamindaines

    Joined:
    Mar 24, 2005
    Location:
    A religiously oppressed state
    #4
    I was talking to someone else about it and they said that it was because of the gamma shift (like you said too) between the QuickTime codec and FCP, do you know how much exactly the shift is? If you do then I can just compensate for it in Compressor's settings.
     
  5. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #5
    I have no idea how much the shift is, but you could always do some trial and error w/some freeze frames.

    Are you compressing the video for the web, DVD, or just to e-mail to someone?


    Lethal
     
  6. Benjamindaines thread starter macrumors 68030

    Benjamindaines

    Joined:
    Mar 24, 2005
    Location:
    A religiously oppressed state
    #6
    Sorry about that type, it should have said "shift" instead of what it turned out as. I am compressing to email to someone, but I want it to look as good as I can get it.
     
  7. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #7
    Are they Mac or PC? Something else to keep in mind is depending on how their monitor is setup what you send them might look different on their monitor then it does on yours. As long as it doesn't look bad (too bright or too dark) I wouldn't worry about it too much in this instance.


    Lethal
     
  8. Benjamindaines thread starter macrumors 68030

    Benjamindaines

    Joined:
    Mar 24, 2005
    Location:
    A religiously oppressed state
    #8
    They are on Mac, I would like the colors to match a little bit better.
     
  9. Laslo Panaflex macrumors 65816

    Laslo Panaflex

    Joined:
    May 1, 2003
    Location:
    Tokyo
    #9
    Yes it is a gamma shift issue. Are you using h264 codec? I have noticed that h264 compressed footage has this issue more so than other codecs. Even worse, it seems that it might only be a playback issue within quicktime for mac, but not for PC. I've noticed the problem since quicktime 7 was released, and it seems they still haven't fixed it.

    To compensate for the gamma shift, load the video in quicktime and bring up the AV controls window. Adjust the gamma to your liking, and that matches the original footage, and use that number in compressor to offset the gamma shift.

    Hope that helps.
     

Share This Page