Connected to Internet but safari says cannot connect to server. Help!!!!!

Discussion in 'MacBook Pro' started by TheShmiggler, Sep 1, 2012.

  1. macrumors newbie


    Dec 10, 2011
    Okay I randomly went on my laptop today , MacBook Pro 10.7.4 and the Internet is stuffing up. It was working perfectly fine up until now but today it had been playing up. The computer says I am connected to the Internet but when I go on safari it says cannot connect to server. I will tell you everything ive done and know to see if that helps. I really need the internet :L

    - iPod connects fine to Internet along with other devices in the house ( so is not a router problem)
    - I also have google chrome on my computer which is not connecting aswell ( this webpage is not available ), other applications do the same thing (app store).
    -it's not a particular website because I have tried many, also tried their IP addresses so the problem doesn't lie there.
    -tried to do diagnostics in network settings but it says I am connected fine.
    -tried everything from restarting safari, resetting preferences and turning the router off, nothing makes a difference.
    -tried connecting the Ethernet cable but safari does the same thing, so it's not just wireless.

    Another note is that it is playing up at the same time that adobe after effects is, which is taking ages to load up and stuck on the media code page or whatever. Need to fix that up to because it won't let me export.

    Anyway I really need someone's help because I require the Internet for a project, why doe it have to stuff up now :mad:
    Thanks for your replies
  2. macrumors 6502a

    Apr 11, 2010
    Can you ping the websites you wish you go to? Both my name and ip?
  3. thread starter macrumors newbie


    Dec 10, 2011
    Okay I tried doing this in terminal on Mac for and one of its ip addresses

    When I ping the adress it continually pings it and tells me how many bytes are received.
    Though when I try the ip adress it pings it but then comes up with a continues flow of request timeout.

    Does this have anything to do with it???
  4. macrumors newbie

    Aug 21, 2012
    Try to turn wi-fi off from the System Preferences and turn it on again.
  5. thread starter macrumors newbie


    Dec 10, 2011
    Already tried that :)
  6. macrumors 6502a

    Oct 21, 2011
    Delete /Library/Preferences/SystemConfiguration and then restart the computer.
  7. thread starter macrumors newbie


    Dec 10, 2011
    That didn't change anything either....
  8. macrumors member

    Feb 3, 2008
    It's an old bug in Safari that has never been fixed by apple, for me it's more prevalent in the latest v6.1.

Share This Page