connecting to a PC with my pb

Discussion in 'General Mac Discussion' started by westicle, Nov 19, 2003.

  1. westicle macrumors newbie

    Joined:
    Nov 19, 2003
    Location:
    Rochester, NY
    #1
    I have a 15" pb running panther and I have a problem connecting to my roommates computer to grab files off of his PC. We're both on the same connection, split with a router. He can get files off of my computer but I can't seem to get any from him. can anyone help me?
     
  2. leet1 macrumors 6502

    Joined:
    Nov 3, 2003
    #2
    Turn off internal firewall and turn on filesharing if you haven't already.
     
  3. hmmm macrumors member

    Joined:
    Sep 10, 2003
    Location:
    UK, NL, USA
  4. AnotherMortal macrumors regular

    Joined:
    Jan 14, 2003
    Location:
    Baltimore
    #4
    This may not make a difference with Panther, but when connecting from a WinXP machine to a WinXP machine there's a "ForceGuest" setting that is on by default. It basically forces you to always log in as guest. (see http://www.nthelp.com/NT6/xp_drive_sharing.htm for more info)

    Try this link from Apple:
    http://docs.info.apple.com/article.html?artnum=125037

    This is a general article from Apple about connecting to shared resources on other platforms.

    What specific symptoms are you having? At work I've got several PCs running XP and several Macs running Panther. Give me some more info, and I'll try to help.
     
  5. westicle thread starter macrumors newbie

    Joined:
    Nov 19, 2003
    Location:
    Rochester, NY
    #5
    turned my firewall off, still the same problem. the symptoms i'm having is that i can't connect to his comp reguardless of what program i try to do it with whether its AIM, or the server connect through finder on my pb. and like i said, he's able to get files off my computer. also when i go to the finder and try to open the network option, it won't open.
     
  6. westicle thread starter macrumors newbie

    Joined:
    Nov 19, 2003
    Location:
    Rochester, NY
    #6
    also, when i go through finder to the networks option, my roommates computer doesn't show up, only mine does.
     
  7. Dippo macrumors 65816

    Dippo

    Joined:
    Sep 27, 2003
    Location:
    Charlotte, NC
    #7
    Re: connecting to a PC with my pb

    Check to make sure that his shares are showing up in HIS network neighborhood on winXP. If he can't access his own shares through network neighborhood, then he is not sharing.

    Also, I sometimes have problems accessing files on other WinXP machines while using WinXP! So I bet this is Windows problem and has nothing to do with the setting on your mac!
     
  8. Dippo macrumors 65816

    Dippo

    Joined:
    Sep 27, 2003
    Location:
    Charlotte, NC
    #8
    Are you sure your roommate is sharing???

    In WinXP:

    Right click on a folder and click on "Sharing & Security..."

    Then click on the warning message

    Check the box beside "Share this folder on the network"

    Then click OK.

    It would probably be best to reboot after that, and then it should work!
     
  9. joker2 macrumors 6502a

    joker2

    Joined:
    Feb 19, 2003
    Location:
    DC area
    #9
    Did you make sure you're in the same "workgroup" ? Some windows installations default to "MSHOME" and OS X's defaults to "WORKGROUP"
     
  10. westicle thread starter macrumors newbie

    Joined:
    Nov 19, 2003
    Location:
    Rochester, NY
    #10
    he is sharing, he is able to share with other windows computers and his setting is on workgroup...this is starting to sound impossible.
     
  11. SiliconAddict macrumors 603

    SiliconAddict

    Joined:
    Jun 19, 2003
    Location:
    Chicago, IL
    #11
    -Make sure his firewall is off (For testing purposes.)
    -Make sure his Server service is running.
    -Have him open up a command prompt and type:
    net share This will give you a list of all shares on the system.
    -Have him go into the properties of My Network Places (There is no such thing as Network neighborhood. That was dropped in '98.) and go into the properties of his NIC and make sure File and print sharing is check marked.
    -I would say try and ping his IP address to make sure you two are at least talking to each other but I don't have a freaking clue how you'd go about doing a ping in OS X. There's got to be a console command or something.

    -I would say it’s a config he's done on his end not yours. How much of a tech head is this guy? If you know your stuff you can really lock down XP to gain very minimum access.
     
  12. SiliconAddict macrumors 603

    SiliconAddict

    Joined:
    Jun 19, 2003
    Location:
    Chicago, IL
    #12
    Oh ya and what OS is he running? if its 9x tell him to upgrade. :p
     
  13. AnotherMortal macrumors regular

    Joined:
    Jan 14, 2003
    Location:
    Baltimore
    #13
    Open up Terminal (Applications -> Utilities -> Terminal) and type ping 192.168.0.1 replace 192.168.0.1 with whatever IP address you want to ping.

    Do note, the ping -a option does not work on OS X. If you want to do a reverse lookup, you can use nslookup 192.168.0.1
     
  14. SiliconAddict macrumors 603

    SiliconAddict

    Joined:
    Jun 19, 2003
    Location:
    Chicago, IL
    #14
    *slaps forehead* Ping isn't MS term it was originally Unix based right. Should have known. :eek:

    Hey quick side question. Does anyone know how to do an ip address release/renew? I have a friend that comes over to the house occasionally with his iBook and we were trying to figure this out. We end up just rebooting the system but there HAS to be a console command that can do this. Anyone?
     
  15. AnotherMortal macrumors regular

    Joined:
    Jan 14, 2003
    Location:
    Baltimore
    #15
    There is, but just upgrade to panther, there is a release and renew button in the network window.

    The poor man's way via GUI is to change the dropdown to manual, and then click apply. Then change it to DHCP again.

    Or use the Locations.
     

Share This Page