Connecting to Windows Server via IP Address

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Makosuke, Nov 10, 2003.

  1. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I've been asking this question on every Mac forum I frequent, and haven't come up with anything yet, but I don't think I've tried the bright crowd here yet (if I already did, sorry!).

    Just about every place where people are discussing Panther has a lot of talk about problems getting Panther to properly browse Windows networks. Network browsing feels a little funky, but I'm actually getting that to work just fine. Ironically, the one thing everybody else seems to be able to do is the one thing I can't: Connect to a Windows server directly using an IP address.

    I'm trying to access a Windows share (running on a WinNT4 server box) that's not on my local network (so browsing or using its computer name isn't an option) by entering it's IP address (smb://###.###.###.###/SHARENAME). In Jaguar, not only would this fail, but I could reproduceably cause a Kernel Panic by trying twice in a row on more than one computer--definitely a bug of some sort (which I reported to Apple).

    Panther doesn't crash, at least, but it sits at the "Connecting" dialogue for about two minutes, then coughs up the error "The Finder cannot complete the operation because some data in [...] could not be read or written."

    Connecting works just fine on a nearby Mac using OS9 and DAVE 2.x, and I just tried installing the Dave 4.1.1 trial, which immediately allowed me to connect to that share (didn't even have to restart). Remove DAVE, and it works no more. More mystifying still, I can even log in and access the files on it using the terminal command "smbclient". (Speaking of which, why doesn't smbmount work any more? didn't that work in Jaguar?)

    So I know the Windows server is working, I know I can connect to it using tools installed by Panther, I know I can connect to it using the Connect To Server dialogue with a 3rd party tool installed, but I just can't get it to work out of the box.

    There's obviously something funky with my network situation causing this, but I can't for the life of me figure out what it is; I'm on a large campus network, trying to connect to a computer at another, smaller location with nothing but the Internet in between the two.

    Any folks with network experience have any suggestions?
  2. moko macrumors newbie

    Sep 21, 2003
    Melbourne, Australia
    Ok, Ill ask the dumb question. You are putting those slashes in as backslashes not forward slashes as in your example? ie smb:\\\share

    Like I said, dumb question but you never know.:D
  3. abhishekit macrumors 65816


    Nov 6, 2003
    akron , ohio
  4. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    Actually, you're supposed to use forward slashes. I always do, and don't have any problems. I just tried using backslashes and it didn't work.
  5. Makosuke thread starter macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Yes, those are supposed to be forward slashes. According the Apple's help, there are two possible formats:




    The top one does indeed fail completely if you try to use backslashes, and works on other computers with forward ones. Apple's help also implies that the latter version with the backslashes is only for DNS names and not IP addresses, which seems to be true--it coughs up an error much faster, although actually I've never gotten the backslash version to work with anything at all.

    Guess I'm alone with this problem.
  6. electric macrumors regular

    Oct 14, 2002
    San Francisco, CA
    I had a problem accessing a P.C. and found out that I had not made any directories open on the P.C. so therefore my Mac saw none to access.

    Hope this helps, I am an eternal NewB when it comes to Windows.
  7. moko macrumors newbie

    Sep 21, 2003
    Melbourne, Australia
    Ahh that makes sense. I dont type the smb and havent had any problems - until I installed panther but thats another story. :D
  8. slowtreme macrumors 6502

    May 27, 2003
    Tampa FL
    Mine is the opposite. My Macs never see the sharename. I have to use IP for everything.
  9. poisonmonkey macrumors newbie

    Nov 10, 2003
    Markham, Ontario, Canada
    I had that problem too.

    What worked for me was to turn ON file sharing under --> System Preferences/Sharing--

    I turned on that and windows sharing and I had no problems afterwards...

    It seems as though in Panther you must type smb:// for IP's...

    btw make sure the folders/drives in Windows are shared!

    If connected via router allow all computers have equal access ie not blocked or filtered out...

    Good luck!

Share This Page