Contacts, iCloud and Duplicate Groups

Discussion in 'Mac Applications and Mac App Store' started by Big Byte, Feb 4, 2013.

  1. macrumors regular

    Joined:
    Jul 7, 2009
    #1
    I recently upgraded to Mountain Lion and implemented iCloud. Everything seems to be working fine, but I noticed that, in the "Groups" list on the left hand side of the Contacts screen, there are two groups for "iCloud", both of which contain the same subgroups (i.e. those that I have created such as Business Contacts, Clients Contact, Family Contacts, etc.). Is this normal? Is there a way that I can delete one of these groups to clean up the screen a bit? Thanks.
     
  2. macrumors demi-god

    Shrink

    Joined:
    Feb 26, 2011
    Location:
    New England, USA
    #2
    This happened to me.

    Try going to System Preferences > Mail, Contacts and Calendars

    Look in the left hand column and see if iCloud appears twice.

    If it does,highlight one of the iCloud accounts. go to the bottom, click on "-" (minus) to delete one of the accounts.

    I would always suggest making sure your stuff is backed up before you do it.
     
  3. thread starter macrumors regular

    Joined:
    Jul 7, 2009
    #3
    Thanks for the suggestion, but iCloud only appears once in System Preferences > Mail, Contacts and Calendars.
     
  4. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #4
    Are you certain they are both iCloud? Often when you turn on iCloud it will import your "On My Mac" contacts and groups while leaving them in place, so you end up with both.

    It look like:

    Code:
    iCloud
    --Family
    --Friends
    
    On my Mac
    --Family
    --Friends
     
  5. thread starter macrumors regular

    Joined:
    Jul 7, 2009
    #5
    Let me clarify what happened:

    1) I installed Mountain Lion
    2) I activated iCloud
    3) iCloud was acting funny, so I unchecked everything in System Preferences > iCloud. In doing so, I was given the option to merge my contacts back to On my Mac, which I did
    4) Contacts now has two iCloud categories (not iCloud and On my Mac)

    I'm thinking something happened around step 3), but I am not sure. Maybe you're on to something?
     
  6. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #6
    Hmmm... odd.

    Check in this screen in System Prefs and make sure you don't have two iCloud accounts entered.

    [​IMG]

    I'm also wondering if in this process that second iCloud heading you have is really an On my Mac group that just got relabeled incorrectly as part of the import back to On my Mac.

    Can you experiment and figure out which might be the On my Mac one and delete it? As I recall if you delete all contacts from On my Mac the whole heading goes away.

    Go to Contacts preferences and tell it to make iCloud the default for new contacts.

    Before you do anything, do a command-a to select all contacts then in the File menu select Export / Export vcard and save it to the desktop. This will give you a local backup of all your contacts in case this gets sideways.
     
  7. thread starter macrumors regular

    Joined:
    Jul 7, 2009
    #7
    I tried doing that, but it didn't work. Interestingly, though, in Contacts Preferences, under default accounts, there is both On my Mac and TWO iCloud accounts. Shouldn't there be only one iCloud account? Does this mean anything?
     
  8. thread starter macrumors regular

    Joined:
    Jul 7, 2009
    #8
    Turns out that there were two iCloud accounts in in Contacts > System Preferences > Accounts and deleting one of them fixed the issue. Thanks for the help, everyone.
     
  9. macrumors newbie

    Joined:
    Aug 13, 2013
    Location:
    Houston, TX
    #9
    Same thing happened to me!
    How did you manage to delete the extra account? I tried and it takes me to "Internet Accounts". Frustrating.
     
  10. macrumors newbie

    Joined:
    Sep 6, 2014
    #10
    Disconnect twice

    I had this problem with two iCloud groups, but only one iCloud account in the Contacts preferences pane. Here's what worked for me:

    Go to Contacts -> Preferences -> Accounts, highlight the iCloud account and click minus at the bottom to remove the account. This will then offer to take you to "Internet Accounts", as previously described in this post.

    In "Internet Accounts", (which is also System Preferences -> Internet Accounts), select your iCloud account and uncheck Contacts.

    You will be asked "Do you want to keep a copy of your iCloud contacts on this mac?" and offered the options "Delete from Mac", "Cancel", or "Keep Contacts". Choose "Delete from Mac" (which is NOT the highlighted option).

    When you return to Contacts, one of your iCloud groups will be gone.

    To make sure there were no lingering problems, I repeated the process for the other iCloud group, so that there were no iCloud groups left in Contacts. Then I returned to System Preferences -> Internet Accounts and re-enabled (re-checked) Contacts in iCloud. This resulted in only one iCloud group in Contacts. I'm not sure this repeat step is required, but I thought a clean reconnect was a good idea.
     

Share This Page