Copying files in Finder

Discussion in 'macOS' started by MrVegas, Oct 6, 2005.

  1. MrVegas macrumors regular

    Joined:
    Jun 4, 2005
    Location:
    Columbia, Md.
    #1
    Here's a question for you Finder experts.

    My powermac and PC share a home network.
    I just copied a folder called "Rock" with 100 songs in it from my PC to my Mac.
    Then I added 5 more songs to the same folder on my PC.
    When I tried to copy the folder from the PC to the Mac again, I was hoping that it would only copy the 5 songs.
    Instead it only gave me the option of overwriting the original 100 songs along with copying the 5 new songs.

    Is there any way to copy whole folders over and have Finder be smart enough to recognize the five new songs and copy them only?
     
  2. iSaint macrumors 603

    iSaint

    Joined:
    May 26, 2004
    Location:
    South Mississippi y'all, near the water!
    #2
    I think if you select do not overwrite, the five new songs will be placed in the folder regardless.
     
  3. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #3
    I don't think there's a way to do exactly how you want it, but you'd get the same result by doing it as follows:

    1. Open the source folder and select everything (command-A)
    2. Copy the selection to the destination folder
    3. Finder will give you a warning that one of the files already exists in the destination location. Select the "Apply to all" checkbox then click "Don't Replace"

    This will then copy all the files that don't already exist in the destination folder.
     
  4. MrVegas thread starter macrumors regular

    Joined:
    Jun 4, 2005
    Location:
    Columbia, Md.
    #4
    When I do as you suggest, I do not get the "Apply to all" checkbox

    All I see is "Stop" or "Replace"

    If I select "Replace" it just overwrites everything
    :(
     
  5. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #5
    It sounds like you are still copying the folder itself. Make sure to open the source folder, select the files inside it (by typing command-A), then copy the files by dragging them to the destination folder. You should get a dialog like this:
     

    Attached Files:

Share This Page