crazy itunes 7 sound prob, please help!

Discussion in 'Mac Apps and Mac App Store' started by Chris3125, Sep 20, 2006.

  1. Chris3125 macrumors member

    Joined:
    Aug 20, 2005
    #1
    since installing i tunes 7 it has totally messed with my sound. i tunes now ignores all the settings on my sound card and eq settings and just plays the music through the front 3 speakers. i have an audigy 2 sound blaster with 7.1. thing is it works with everything else that produces sound, WMP etc. just when playing music in i tunes sound comes through the front 3 only and totally flat, no EQ or EAX at all.

    anyone have any ideas?
     
  2. lovely macrumors newbie

    Joined:
    Nov 28, 2004
    #2
    omg

    It happened to me too!! For me, I haven't notice a difference when I listen to iTunes on my iBook. However, my two iPod Nano sound really weird when I listen to them in my car. The white one (i have both black and white) sounded okay yesterday but right after I charged it last night, it sounded terribly flat this morning. Seems like it ignores all my EQ settings.

    How do I downgrade my iTunes back to the previous version?
     
  3. Vanilla macrumors 6502a

    Joined:
    Mar 19, 2002
    Location:
    Atlanta, GA
    #3
    I've noticed that my 5th Gen iPod sound is now skewed to the left and is very flat. It was fine up until I upgraded to iTunes 7; since then the sound in iTunes via my mac is fine but the iPod is messed up. I'm going to try and fix it by resetting the iPod but if that fails I'll be looking to downgrade iTunes back to the previous release.
    Vanilla
     

Share This Page