Creating app from 5.1 to higher

Discussion in 'iOS Programming' started by Mvkoe, Jan 22, 2013.

  1. macrumors member

    Mvkoe

    Joined:
    Aug 4, 2008
    Location:
    Belgium
    #1
    Hey

    I'm having some problems, i want to make my app that is min required iOS 5.1 to higher. Now the problem is i have xcode Version 4.5.2, so it's basic always on iOS 6. and i don't really know how it works with, that i want to start making it for 5.1 and higher.

    Grz
     
  2. macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #2
    Click on your project icon in the top left of Xcode, then choose the Build Settings (I think) tab and change the Deployment Target from whatever it is now to 5.1.
     
  3. thread starter macrumors member

    Mvkoe

    Joined:
    Aug 4, 2008
    Location:
    Belgium
    #3
    But I can find 3 times deployment Target (project, target, build settings). I can change it twice in the project and target, but in the build settings it only says iOS 6, and nothing else.

    Same as the storyboard info, do i need to set that deployment to iOS 5 also?
     
  4. macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #4
    Maybe you need to download the other SDKs? Go into Xcode's preferences and check the downloads tab.

    Also, why bother supporting iOS 5.1? Last I've seen, iOS 6 had surpassed 70% and that was Pre-Christmas, I expect they're past 80% by now. And by the time your app ships, it'll be higher still.
     
  5. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #5
    You are probably confusing Base SDK with iOS Deployment Target in your Build Settings. You should only need to change the setting in your Summary tab and you should be good to go.
     
  6. thread starter macrumors member

    Mvkoe

    Joined:
    Aug 4, 2008
    Location:
    Belgium
    #6
    Okay thanks! Didn't found this on the internet tough..

    Because i'm still running 5.1.1 for my jailbreak lol..
     
  7. macrumors regular

    Joined:
    Aug 23, 2011
    #7
    My iPad 1 can't run iOS 6, so I always build for 5.1 too. Not sure what the status is for other iDevices, but I suspect there are other "not that old" devices out there which shill have a lot of life in them, but just can't run iOS 6 or apps that require it.
     
  8. macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #8
    Really? I was under the impression every iOS 5 compatible device was also iOS 6 compatible. I think my iPhone 3Gs is running iOS 6, but its battery is dead and I can't be bothered to power it up just to find out...
     

Share This Page