creating nfs mounts for linux

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by mnkeybsness, Jan 17, 2004.

  1. mnkeybsness macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Location:
    Moneyapolis, Minnesota
    #1
    [backstory] i'm running myhtpc on my home theater computer that i built, but i want to get away from windows, so my room mate and i are working on getting mythtv (link) running. in order for me to switch, i need to be able to automount my music hard drive on my mac to the home theater computer. since mythtv is run on linux, we figure the best idea would be to make an automount of an nfs from my music hard drive on my powermac[/backstory]

    now: i followed the instructions on this pdf for creating mac os x NFS shares. everything seems to have worked fine, but i continue to get a message of (first attempt) timeout or (second attempt) host refused connection.

    my settings are to allow all clients, with maproot=nobody, read-only, my router set as network (network=192.168.1.0) and mask=255.255.255.0

    can anyone see an error or have some experience setting this up?
     
  2. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #2
    Do you have your firewall turned off? I haven't done NFS on a Mac, but on other *nix boxes you basically end up leaving almost all of your non-priviledged ports open (ports > 1024) because nfs doesn't go over one specific port.

    (I didn't read the pdf, but I did search it and didn't find "firewall" in there - so if this is covered, sorry 'bout that)
     
  3. mnkeybsness thread starter macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Location:
    Moneyapolis, Minnesota
    #3
    i opened up port 2049, which is the standard NFS port... still getting that timeout.
     
  4. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #4
    Some services under NFS use RPC, and can use other ports than 2049 which are randomly chosen by default. Additionally portmap is going to want to use port 111.

    That's why I suggested turning the firewall off. It only takes a minute or two for the test, and if that doesn't fix it then you re-enable it and move on. If it works with the firewall off, then you've narrowed down the problem significantly.

    There are ways to force the various pieces of the NFS service to use fixed ports, if it turns out to be the problem.

    Another completely separate option would be to export your music folder via Samba, and automount it that way.
     
  5. davy the bunny macrumors regular

    Joined:
    Jan 9, 2003
    Location:
    Dallas
    #5
    Allow Higher Ports

    I was getting this same error for a while! Okay, I'm not sure of where or what the option is for you but I know that in my situation (RedHat 9 NFS Share and Mac OS X Clients) on the RedHat box I had to go into the NFS configuration and tell it to "Allow Connections from ports higher than 1024". I don't know too much about how to do this with /etc/exports or if it's possible. But here's a screenshot of the box I had to check in the gui.
     
  6. davy the bunny macrumors regular

    Joined:
    Jan 9, 2003
    Location:
    Dallas
    #6
    [edit]
    Sorry, I think I have the server and client backwards. Sorry, nevermind. . . [/edit]
     

    Attached Files:

  7. mnkeybsness thread starter macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Location:
    Moneyapolis, Minnesota
    #7
    that's all well and good, but i'm using knoppmyth, which uses fvwm... i'm gonna need to do that command-line style... any help on that one?
     

Share This Page