CS3 Crashing

Discussion in 'Mac Apps and Mac App Store' started by Aperture, Mar 13, 2007.

  1. Aperture macrumors 68000

    Aperture

    Joined:
    Mar 19, 2006
    Location:
    PA
    #1
    Hi Everyone. I just did the 10.4.9 update and now I am having trouble with Photoshop CS3. (worked fine before) When I go to File > Save, it instantly crashes. Thats it. It crashes. This happens every single time. Please, any help appreciated.

    Thanks
     
  2. SpaceJello macrumors 6502

    Joined:
    Dec 2, 2006
    #2
    i haven't updated to 10.4.9 yet... does anyone else have this same problem, i am hesitant if this is the case.
     
  3. Mossman macrumors member

    Joined:
    Mar 24, 2006
  4. Aperture thread starter macrumors 68000

    Aperture

    Joined:
    Mar 19, 2006
    Location:
    PA
  5. bmcgrath macrumors 65816

    bmcgrath

    Joined:
    Oct 5, 2006
    Location:
    London, United Kingdom
  6. Laslo Panaflex macrumors 65816

    Laslo Panaflex

    Joined:
    May 1, 2003
    Location:
    Tokyo
    #6
    Just reinstall it, I had some issues a few weeks ago and a reinstall fixed it.
     
  7. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
  8. Aperture thread starter macrumors 68000

    Aperture

    Joined:
    Mar 19, 2006
    Location:
    PA
    #8
    I've already reinstalled 3 times. Its under Rosetta to run the plugins that aren't yet accessible.
     
  9. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #9
    OK, I see that you've already brought this up with Adobe, and that it's not only a problem with saving. the dump isn't especially informative, except that it looks like the problem may be outside Photoshop, on the x86 side. Perhaps something went wrong with the OS X update install.
     
  10. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
  11. Peace macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #11
    Have you updated to the new QT ?

    Make sure you have then repair permissions.

    It could also be the Rosetta plug-ins you have won't work with 10.4.9

    In order for this to be a "bug" it must be reproducible 3 times under the same state and/or conditions.
     
  12. Aperture thread starter macrumors 68000

    Aperture

    Joined:
    Mar 19, 2006
    Location:
    PA
    #12
    I just installed CS2 and it is also crashing. I was able to save the crash log again, and have posted it here. Please take a look at this as I am open to all solutions. I am beginning to feel you guys are correct in the fact that perhaps a plugin isn't compatible with 10.4.9.

    Is there a way to revert back to 10.4.9?

    Thanks
     
  13. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #13
    Downgrades generally have to be done the hard way, archive and install followed by an update to the OS X version you want. This is the kind of situation that makes bootable disk-to-disk backups so popular :eek:

    Before you get into that, perhaps you could pull out all your third-party plugins, see if the problem goes away, then add them back one by one to see if one of them is causing the trouble.

    Also, if you use anything at all on the system that relies on Application Enhancer, disable it. The Insanity people like to claim that APE is incapable of breaking things, but that's not quite true; anything loaded by APE certainly can cause grief. Anything that relies on SIMBL has the same potential to get in the way.
     
  14. Aperture thread starter macrumors 68000

    Aperture

    Joined:
    Mar 19, 2006
    Location:
    PA
    #14
    I did an Archive & Install. 'Now updating to 10.4.8. The question is whether I should try updating to 10.4.9 again? Perhaps the problem won't arise as tons of others have CS3 working fine in 10.4.9. One step I wished I had tried was making a new user account and testing it on there. Oh well.

    I'll keep you posted.
     
  15. Aperture thread starter macrumors 68000

    Aperture

    Joined:
    Mar 19, 2006
    Location:
    PA
    #15
    Nope. I'm on 10.4.8 and it is STILL crashing with saves. How can this be?
     
  16. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #16
    You could go ahead and give the new user thing a shot (archive and install will have preserved any weirdness in your user account). I'd give the disk a check (not permissions, the disk test) to see if anything is out of whack, and maybe even run the hardware tests (this one's unlikely since it's only one app and choosing a single place to crash, but PS does give the system a good workout so it's not impossible).
     

Share This Page