Ctrl-Cmd-D Not Working?

Discussion in 'macOS' started by lu0s3r322, Mar 17, 2007.

  1. lu0s3r322 macrumors 6502a

    Joined:
    Nov 28, 2005
    Location:
    Illinois, USA
    #1
    Whenever I press Ctrl-Cmd-D for dictionary definitions while I hover, the right click menu just comes up. I know it works in Safari but I've haven't gotten it to work.
     
  2. Blubbert macrumors 6502

    Joined:
    Nov 1, 2006
    #2
    Im not sure, but i think it only works in Cocoa apps.
     
  3. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #3
    Does it show up as being mapped correctly and turned on in System Preferences --> Keyboard & Mouse --> Keyboard Shortcuts?
     
  4. lu0s3r322 thread starter macrumors 6502a

    Joined:
    Nov 28, 2005
    Location:
    Illinois, USA
    #4
    it says cmd d but when i try that in safari it just bookmarks the pg.
     
  5. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #5
    You're sure it's not set to Command-Control-D?
    Picture 2.png

    You can either manually set it or click Restore Defaults if you're worried about other shortcuts being messed up and you haven't customized anything you want to keep that way.
     
  6. lu0s3r322 thread starter macrumors 6502a

    Joined:
    Nov 28, 2005
    Location:
    Illinois, USA
    #6
    ok well i pressed restore defaults but it still shows the right click menu if i press the combo and then click on a word
     
  7. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #7
    You have to do the keys in the order of: Control + Command + D
    Just to clairify
     
  8. obesecat55 macrumors newbie

    Joined:
    Feb 12, 2007
    #8
    And you don't have to click. It should work when you simply hover the mouse over a word and press control + :apple: (Command) + D.

    So far I've been testing this out- it only works in Safari, TextEdit, Dictionary App, Automator, iChat, and probably more, but the point is that supported apps are limited.
     
  9. lu0s3r322 thread starter macrumors 6502a

    Joined:
    Nov 28, 2005
    Location:
    Illinois, USA
  10. mpipolo macrumors newbie

    Joined:
    Nov 13, 2007
    #10
    CTRL-CMD-D not working at all on Late 2007 MacBook

    Hey, I found this thread by searching Google.

    Trouble is, I use this Ctrl-Cmd-D feature ALL the time on my Macs, whether for Thesaurus or Dictionary. I have a 12" iBook with Tiger and an ('06) MacBook, and I just upgraded my iBook to a late 2007 model MB.

    This dictionary panel has not worked at all on the new computer. It is set in the Keyboard Shortcuts preferences, but no go. I've even changed the key association, and it still doesn't work. Every other shortcut in the list works fine.

    It's very strange, and it's the only misgiving I have had yet with this computer. Any ideas what the problem could be?
     
  11. thewhitehart macrumors 6502a

    thewhitehart

    Joined:
    Jul 9, 2005
    Location:
    The town without George Bailey
    #11
    I'm having this exact problem too on my new Santa Rosa macbook running 10.5.1. I'm running 10.5.1 on my iMac, and the feature works.

    This is one of my favorite features, a "can't live without" feature, really. I'm addicted to it. Apple support discussions has no solution for it either.
     
  12. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #12
    Err no you don't as discussed in this thread
     
  13. chadvonnau macrumors newbie

    Joined:
    Apr 12, 2008
    #13
    Sorry to resurrect an old thread, but this is still coming up as the top Google result for "CTRL - CMD - D not working".

    If you're having this issue, and nothing else works, try the instructions here:

    http://support.apple.com/kb/TS1896

    The article is posted as the solution to a different issue, but it also fixes the hotkey problem. Thanks to Jose Paulson on the Apple Discussion Boards for figuring this out.
     

Share This Page