Cut /paste hyperlink in Excel

Discussion in 'Mac Applications and Mac App Store' started by bgsnmky, Jan 5, 2013.

  1. macrumors regular

    Joined:
    Sep 22, 2012
    #1
    Driving me crazy..

    is there a way to copy the http:url and past it into the hyperlink window?

    It is a very long url, and It appears I can only type it..but I really need to cut and paste it.

    But it will not let me.
     
  2. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    By "hyperlink window" do you mean the address bar of your browser? If so:

    Right-click on the cell with the hyperlink and copy, then paste into your browser.
    Right-click on the cell with the hyperlink and select "Open Hyperlink"
     
  3. thread starter macrumors regular

    Joined:
    Sep 22, 2012
    #3
    not really...sorry..let me try again.

    I go to the browser in safari..I can highlight and select copy

    I got to excel - and in a cell - go to menu - select Insert and then Hyperlink.
    The next window that pops up is the hyperlink window where you can type in the hyperlink and description.
    But I just want to PASTE it in..and it doesn't let me
     
  4. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    That works for me, but why not just click on the cell where you want it and paste it there? Does that work? If not, have you checked to make sure it's not a protected cell?
     
  5. thread starter macrumors regular

    Joined:
    Sep 22, 2012
    #5
    I can insert in a cell just fine.

    But sometimes you want the cell to say: Couples swept away, but it goes to the website that is like this: www.couples.com/sweptaway.com

    basically I have tried everything to paste my url in the place where the error is.
    This one is not long..but I have one that is ReALLY long

    [​IMG][/IMG]
     
  6. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Try this: paste the link in a cell, then right-click the cell and Edit Hyperlink. The link should be populated and you can edit the display text.
     
  7. macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    #7
    You didn't mention how you're trying to paste into that field. I know from experience that right-click pasting into the "Edit hyperlink" dialog doesn't work in either the Mac or Windows versions of Excel.

    However you can still paste with Command-V (or Ctrl-V in Windows)
     

    Attached Files:

  8. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Good catch! I didn't even think of right-clicking to paste, since I'm so used to Command-V. It never occurred to me that someone might not try the keyboard command.
     
  9. thread starter macrumors regular

    Joined:
    Sep 22, 2012
    #9
    :)

    and I am so used to the mouse! and I do it in windows all the time.


    so still can't get it to work..there has to be a way....
     
  10. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    Did you try the suggestion in post #6?
     
  11. bgsnmky, Jan 5, 2013
    Last edited: Jan 5, 2013

    thread starter macrumors regular

    Joined:
    Sep 22, 2012
    #11
    Yes. When you right click and edit hyperlink. The link is in the dist text already. It looks like the picture I posted. And same thing. Cant get the link to paste

    Does it work for you Guys
     
  12. macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    #12
    When I right click and edit the hyperlink, there's no problem pasting a link for me.
     
  13. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #13
    If you paste the link in the cell (just click on a cell and Command-V to paste), then afterwards you right-click the cell and Edit Hyperlink, you no longer have to paste the link, as it's already there. You can simply click in the Display field and edit that to your liking, but the link is already there.
     
  14. thread starter macrumors regular

    Joined:
    Sep 22, 2012
    #14
    I am going to have to call apple care. I know you guys are saying that should work. BUT it doesn't.

    It still shows in the Display field when I select edit hyperlink. It should be showing in the Link To, but the link actually shows up in teh Diplay field and not in the Link To field.
     
  15. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #15
    So if you paste the link in a cell, then right-click in the cell and select Edit Hyperlink, you don't see the link in both the "Link to:" and "Display:" fields?
    ScreenCap 2013-01-07 at Mon, Jan 7,1.16.07 PM .PNG
    If so, you might try deleting the Excel plist and then relaunch Excel. The plist is located here:

    /Users/yourusername/Library/Preferences/com.microsoft.Excel.plist
     

Share This Page