iPhone Cydia: Error Couldn’t configure pre-depend dpkg for ncurses, probably a dependency cy

Discussion in 'Jailbreaks and iOS Hacks' started by eelinnah, Feb 5, 2013.

  1. macrumors newbie

    Joined:
    Apr 2, 2012
    #1
    Hello,
    I keep on getting this message: Error Couldn’t configure pre-depend dpkg for ncurses, probably a dependency cycle.
    I have been trying to use ifile to delete the unnecessary playlist, and reinstall the cydia by re-JB with redsn0w, but nothing changed.
    It is still appearing: Error Couldn’t configure pre-depend dpkg for ncurses, probably a dependency cycle.
    where can I download some debs? How can I fix the "ncurses" or "dependency cycle", please?
    There must be an angel somewhere hiding with the right solution for me!
    Thank you very much in advance!
    Eelinnah
     
  2. macrumors newbie

    Joined:
    Feb 17, 2013
    #2
    Not sure if you've received a reply yet, but this just happened to me. All you have to do is re-jailbreak it using Evais0n. You don't need to restore first, simply just jailbreak on top of your current jailbreak.

    Voila!
     
  3. macrumors newbie

    Joined:
    Apr 5, 2013
    #3
    Problem solved

    Hi, i had the same problem and searched everywhere for help. I can confirm that the above advice works. I rejailbreaked my ipad2 with evasi0n even though evasi0n advised against doing it and now my cydia and all apps are working fine. It updates everything that needs to be updated and i can view my installed apps now but i couldnt before fixing the problem. I was wary of diong it but it was my only option unless i wanted to lose my jailbreak altogther by restoring and updating software via itunes. Hope this satisfies some doubtful members
     
  4. macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #4
    He didn't give his firmware, so evasi0n might not be appropriate, besides that it is very ill advised to re-jailbreak.


    See above.

    @OP
    It looks like you tried to install a .deb which is dependent on other .deb's
    Find out which app you where installing and what is needed.
     
  5. macrumors newbie

    Joined:
    Apr 5, 2013
    #5
    I did not intend to ill advise anyone reading my comment. I was just letting others know that the advice given above worked for me. It is upto the individual person to do it or not. So i apologise if my comments were ill advised
     
  6. macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    Like you said yourself the evaders explicitly say it is not advised to re-jailbreak, overwriting Cydia tends to create more problems than it will solve.

    For most issues there are other option, asking for advise in this or other forums such as ModMyi is best as there are very knowledgeable people who are more than willing to help.

    Re-jailbreaking is a last resort only as it has a high risk of boot-loops and a restore to a non-jailbreakable firmware.

    I'm glad it worked for you but for others it might not be the solution.

    @OP
    reseting Cydia might help as well.

    use ifile or ifunbox:

    Navigate to /private/etc/apt/sources.list.d

    Delete the file "cydia.list"

    Navigate to /var/lib/apt/lists

    Delete all of the files in this folder except the one called "lock"

    Navigate to /var/lib/apt/lists/partial

    Delete all of the files in this folder

    Navigate to /var/lib/cydia

    Delete the file "metadata.plist"

    Restart Cydia. You should be at the first screen you saw when you first started Cydia: What kind of user are you? Make your selection and Cydia will re-generate the default sources.
     
  7. macrumors newbie

    Joined:
    Apr 5, 2013
    #7
    hello there.
    i have done all your above steps except for this "Navigate to /var/lib/apt/lists/partial". i don't see the partial folder at all.

    now i am at Cydia first screen but after choosing the user, it will automatically shut down and won't open.

    Pls advise.
    thanks
     
  8. macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #8
    Are you the OP?

    Are you sure you are in jailbroken mode?

    Try to just boot with redsn0w
     
  9. macrumors newbie

    Joined:
    Aug 30, 2014
    #9
    Curia help

    I went through and deleted all that was asked and it still gives me the error. When I re load the firmware it gives me that error. Is that the problem? If I delete it and re install the firmware will that fix it or is there something that I need to do
     
  10. macrumors newbie

    Joined:
    Aug 30, 2014
    #10
    Cydia help

    Jszingel;19545418]I went through and deleted all that was asked and it still gives me the error. When I re load the firmware it gives me that error. Is that the problem? If I delete it and re install the firmware will that fix it or is there something that I need to do? I am. Noticing that it is doing this when I install anything. That is what I was having problems with prior to trying what
    Bias noted above.
     
  11. macrumors newbie

    Joined:
    Nov 16, 2014
    #11
    Please Help!

    I have this problem too can somebody send me the dfgk files! my email quintentutaki139@gmail please!
     

Share This Page