Cydia gets stuck on done: Packages???

Discussion in 'Jailbreaks and iOS Hacks' started by zkm1223, Dec 21, 2011.

  1. macrumors newbie

    Joined:
    Dec 21, 2011
    #1
    Hi,

    I have upgraded to iOS 5.0.1 on my iPhone 4 GSM. I have jailbroken with redsn0w 0.9.9b9d and I have tried with sn0wbreeze v2.8b11

    However when I open cydia, I wait for the stuff to download at the top of the screen. It gets stuck at "done: packages". If I click cancel and try adding sources, the black screen with the writing comes, it seems like its going fine until the end where the progress bar is complete and it says "done: packages". Again it gets stuck here as well.

    I cannot get any tweaks or anything. When I click on any sources like BigBoss or repo666 or any of the default ones, nothing comes up. Its just a blank screen.

    How can I fix this? it was working fine when I was on 4.3.5. I have tried many times with redsn0w and sn0wbreeze but its always the same
     
  2. thread starter macrumors newbie

    Joined:
    Dec 21, 2011
    #2
    I have let it run for about half an hour and it stays stuck at done: packages.

    Also in the past it normally took a few minutes to complete.

    I have searched around more on the net and have found a solution.

    Step 1: Go to manage>sources

    Step 2: Edit> delete all of the sources except Cydia/telesphoreo (saurik)

    Step 3: Go to "Changes" page (next to manage at the bottom of the screen)

    Step 4: hit refresh (top left)

    Step 5: Go back to manage>sources and add sources

    It worked for me. I just need the default sources which I initially deleted. Can some please post them here. Thanks
     
  3. macrumors newbie

    Joined:
    Dec 21, 2011
    #3
    This fix doesn't work for me because when I click on Sources there is nothing listed there. Have tried re-jailbreaking and reinstalling Cydia and no matter what I do I can't get Cydia to show any sources whatsoever.

    Know how to sort this out?
     
  4. thread starter macrumors newbie

    Joined:
    Dec 21, 2011
  5. macrumors newbie

    Joined:
    Dec 21, 2011
    #5
    Well can you run through the exact process you did from Jailbreaking up to being able to apply the fix you mentioned above? Did you load Cydia and cancel the updating sources? What mode did you boot Cydia in (User/Developer etc).

    Anything like that would be helpful.
     
  6. thread starter macrumors newbie

    Joined:
    Dec 21, 2011
    #6
  7. macrumors newbie

    Joined:
    Dec 21, 2011
    #7
    How did you get iFile?

    ----------

    Ok I figured out an alternate way to remove the sources if they are not showing in the Manage > Sources part of Cydia.

    Instead click Sections > Repositories, click on the repo and click Remove. Fingers crossed its working for me now.

    Now to find a way to install ultrasn0w if the repo is down...
     

Share This Page