Cydia won't open on iPhone 4 ios 4.3 jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by TheAmoryWars, Mar 15, 2011.

  1. macrumors newbie

    Joined:
    Apr 10, 2008
    #1
    I'm using this guide to jailbreak

    http://iphoneblogr.com/2011/03/jail...-using-pwnage-tool-firmware-bundles-tutorial/

    but at the last step, the guide says to enter

    cd desktop/tetheredboot
    ./tetheredboot iBSS kernel

    This DOES prompt me to enter DFU mode, but once my phone does and then the injection attempt starts, it fails.

    Here's what my terminal shows:

    ibusb:error [darwin_reset_device] ResetDevice: device not responding
    Exploit sent
    Reconnecting to device
    libusb:error [darwin_close] USBDeviceClose: no connection to an IOService
    Waiting 2 seconds for the device to pop up...
    Connection failed. Waiting 1 sec before retry.

    Can anyone PLEASE offer some help on how to fix this? My Cydia app is starting at me on my home screen, but when I open it, it instantly re-closes. Thanks so much.
     
  2. macrumors 6502a

    gravytrain84

    Joined:
    Jun 24, 2010
    Location:
    LA
    #2
    :confused:
     
  3. macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #3
    What a surprise, having cydia problems for a jailbreak that doesn't even exist!

    Wait for the dev team to release something instead of some bozo the clown cobbling together a jailbreak and putting it out on some half !@#$ site.

    Have you considered asking the people that run that site where you found these ridiculous instructions to help you instead of bringing your problem to a completely different site?
     
  4. macrumors 6502

    cookiesnfooty

    Joined:
    Jul 1, 2009
    Location:
    Harrogate
    #4
    I don't know about the jailbreak he used but one definately exists.
     
  5. macrumors regular

    Joined:
    Jun 30, 2010
    #5
    That's your first problem. 4.3 Jailbreak is useless as Mobile substrate does not work. And most of the apps on Cydia that use MS will not work

    Check with this site for the latest new on Jailbreak. http://blog.iphone-dev.org/
    Why go to some hack page and not go to the source?? This is what I dont understand.

    Also what I dont understand is why do people jailbreak a devive when they have no idea what to do?
     
  6. macrumors 68020

    Joined:
    May 1, 2009
    #6
    But mobile substrate has been updated already. Though the roll out hasn't yet happened, there is a way to get your hands on it.
     
  7. macrumors newbie

    Joined:
    Mar 15, 2011
    #7
  8. macrumors member

    Joined:
    Sep 12, 2008
    #8
    use the command:

    /Users/username/Desktop/tetheredboot -i /Users/username/Desktop/iBSS.n90ap.RELEASE.dfu -k /Users/username/Desktop/kernelcache.release.n90
     
  9. macrumors regular

    Joined:
    Jun 23, 2010
    #9
    And run tetheredboot as administrator just in case
     
  10. thread starter macrumors newbie

    Joined:
    Apr 10, 2008
    #10
    all that does is produce the following message:


    sh: /Users/Dante/Desktop/tetheredboot: is a directory
    sh-3.2# cd desktop/tetheredboot
     
  11. macrumors regular

    Howdr

    Joined:
    Dec 18, 2010
    #11
    It does exist, Dev team released Sn0wbreeze

    4.3 Tethered JailBreak
     
  12. macrumors 604

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #12
    Ugh. MobileSubstrate worked FINE before it was updated. The only issue was that if it crashed (never did for me) you would have to reboot. Since it's a tethered JB you'd have to be near a computer and the necessary files to do so. Now that it's patched there are no issues.

    I've been running 4.3 on my iPhone 4 since the necessary files were available. I've had no problems.
     
  13. macrumors regular

    Howdr

    Joined:
    Dec 18, 2010
    #13
    Its Device.............

    and the JB for 4.3 is beta but I understand it works

    I have not upgraded and will hold out myself, cydia has a warning to not upgrade from Big Boss.
     
  14. QuarterSwede, Mar 16, 2011
    Last edited: Mar 16, 2011

    macrumors 604

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #14
    I used RedmondPie's guide (which as far as I can tell is the original source). The only difference is they forgot the switches (-i & -k) when entering the terminal commands which has already been mentioned.

    Put everything in the same folder (your desktop ought to work if that's where it is) then:

    Put iDevice in DFU mode by shutting it down. Then hold standby and home for ten seconds (mississippi) then release standby and continue holding home for another 10 seconds. The screen will look like it's off.

    Then in terminal:

    sudo -s
    enter admin password

    /Users/USERNAME/FOLDER(S)/tetheredboot -i /Users/USERNAME/FOLDER(S)/iBSS.n90ap.RELEASE.dfu -k /Users/USERNAME/FOLDER(S)/kernelcache.release.n90

    Enter

    Note: The above is all one line. So type that all in THEN hit enter. If it's successful it'll start doing it's thing.
    Note2: Recognize that there is a space between "-i /Users/..." & "-k /Users/..."

    The funniest thing about all the whiners in regards to this tethered boot is a lot of the same ones had no problem with it when 4.2.1 was tethered. The hardest part of the tethered 4.3 JB is getting all the correct files and setting up the terminal command to point to the right place. Once you get it to work, running it again (ie. rebooting) is as easy as opening terminal and hitting the up arrow a few times till you get to the command (it saves recently entered commands). Hit enter and you're in.

    It actually takes LESS time to reboot than it did in 4.2.1 when you had to open redsn0w, wait for it do it's thing and then follow the instructions to get it to reboot.
     
  15. QuarterSwede, Mar 16, 2011
    Last edited: Mar 16, 2011

    macrumors 604

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #15
    Cydia works fine in 4.3. In fact, almost ALL of my 50+ apps/tweaks work perfectly (My mains: My3G, TetherMe, FakeClockUp, iFile, NoAccessorySplashiOS4, SBSettings/Activator, User Agent Faker, Twizzler).

    The only weird thing is when respringing you now get an all white screen instead of a black one with logo. Whoop De Do.
     
  16. macrumors newbie

    Joined:
    Aug 3, 2010
    #16
  17. thread starter macrumors newbie

    Joined:
    Apr 10, 2008
    #17
    I forgot to mention my baseband (Modem Firmware) is 04.10.01

    Is this what's preventing my Terminal commands from working?

    (one website mentioned that snowbreeze would not jailbreak this baseband. Even though I'm trying with Pwnage, I'm wondering if that same restriction applies.) Does anyone know if 04.10.01 is unjailbreakable thru these tethered options? Thanks.
     

Share This Page