darwin bash?....

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by sjjordan, Feb 24, 2004.

  1. sjjordan macrumors 6502

    Joined:
    Jun 10, 2003
    Location:
    United States
    #1
    I'm having trouble connecting to other macs...

    I'm running Panther and my terminal says I'm in -bash? I'm no unix guy, so I'm not sure what's up, but I can't look up things in the manual as it says "apropos: no what is databases in usr/share/man Error executing formatting or display command. System command exited with status 512"

    What's going on??

    Thanks.
     
  2. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #2
    'bash' is your shell just a program which is the interface between the user/terminal and the kernel or the unix type core inside mac os x, called darwin. There are other shells too like tcsh. But I am sure your shell isnt the cause of your problem in connecting to other macs.
    To get the manual help, you have to write 'man xxx' at the terminal. xxx would be the name of the command you wanna look up. But as shell is not a command, it would say 'no manual entry for shell'.
    So if you can give some details about how you are tryiing to connect to the other mac, I am sure a lot of people here would be able to help you..
    cheers
     
  3. sjjordan thread starter macrumors 6502

    Joined:
    Jun 10, 2003
    Location:
    United States
    #3
    I've previously used tsch in Jaguar, but I dont' know how to switch to that shell.

    I don't know anything about bash, so I'm not sure what to do.

    I've previously been able to use ssh to connect to a given computer. I can't do it now that I've upgraded to OS X.3

    Would it be recommended that I stay in the bash shell?
     
  4. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #4
    to change the default shell, open terminal , prefernces, then select 'Execute this command' , it would be the second option, then in the path below write '/bin/tcsh' , close the window, exit, open the terminal again, you are all set
    cheers
     

Share This Page