Dates displayed in German instead of English

Discussion in 'OS X Mountain Lion (10.8)' started by bostich, Jul 27, 2013.

  1. macrumors newbie

    Nov 4, 2012
    I am located in Switzerland. My MBP's system language is English. What's weird is that the date in the menu bar is displayed in German. Today it says "Samstag" instead of Saturday for example.
    The same thing happens in Finder as well. In the column "Date Created" it would say "heute" or "gestern" instead of "today" and "yesterday".
    While this is not a critical issue I am still wondering why this is and how I could change it.
  2. macrumors 601


    Feb 19, 2008
    The Finger Lakes Region
    Some program you have rewrote your Font files. So first go into System Preferences->and make sure English is first in your selection (while your Native Language second). While still in that pane click on the mini-tab for 'Input Sources' and put a checkmark in 'Keyboard & Character Viewer' and then scroll down and select your county's flag. Now when your flag appears in the finder menu you can click on it and switch keyboard layouts.

    Plus clear your fonts cahe by downloading the free program Onyx to clear your Font cache. This should help, Good Luck.
  3. macrumors newbie

    Jun 28, 2013
    In System preferences / Language & Text / Region:

    1. change Region from "Switzerland (Swiss German)" to (for example) "United Kingdom" (or any region preferred English instead of German)
    2. in same panel, change "Currency" from "British Pound Sterling" back to "Swiss Frank"
    3. now you have system in English, with English dates too and Swiss currency.

  4. thread starter macrumors newbie

    Nov 4, 2012
    How could the fonts have anything to do with the language in which dates are displayed? I've never had any problems with fonts, so I am not sure about cleaning the font cache. Plus, I don't need to switch the keyboard layout. I only need one layout which is German (Switzerland).

    The second suggestion is not bad, but between Switzerland and the UK there are some differences as to how decimal signs are used in numbers. If I chose UK as region and Swiss Franc as currency I would still have to customize decimal signs.

    It seems to me that the point simply is that the names of days are determined by the "region" setting in the prefs, as opposed to the "language" setting. So if I want my system language to be English but the region set to Switzerland I just have to accept German names for the days of the week.
  5., Jul 28, 2013
    Last edited: Jul 28, 2013

    macrumors newbie

    Jun 28, 2013
    Yes, "Customize" button (in Region / Numbers section of System preferences) is for that.

    Also, use "Belgium" region instead of "UK", for currency placement after number.

Share This Page