dead/stuck pixel

Discussion in 'iPod' started by CoMpX, Jan 11, 2006.

  1. macrumors 65816

    CoMpX

    Joined:
    Jun 29, 2005
    Location:
    New Jersey
    #1
    When I turned on my 5G iPod 30GB today, I noticed a stuck blue pixel on the black loading screen. This is most noticeable under darker colors. It goes away sometimes, but it always comes back. I have tried turning it off and on but nothing has helped. Is this something my warranty/Apple will cover?
     
  2. thread starter macrumors 65816

    CoMpX

    Joined:
    Jun 29, 2005
    Location:
    New Jersey
    #2
    I just remembered that I had bought the iPod from BestBuy with the 3-year extended service plan. I was told that this covers anything wrong with the iPod and they just give you a new one if anything is wrong. I will probably be going to BestBuy tomorrow, so I will post back to let you guys know how it turns out.
     
  3. macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
  4. thread starter macrumors 65816

    CoMpX

    Joined:
    Jun 29, 2005
    Location:
    New Jersey
    #4
    I thought about that, but the whole front of the iPod is plastic and it protects the LDC underneath, so when you touch the iPod's screen, you are just touching the plastic over it.
     
  5. macrumors regular

    ToastMaster

    Joined:
    Nov 10, 2005
    Location:
    Tacoma, WA
    #5
    I thought I had the same problem for a while, but I think it was just some water or something under my invisibleshield. I rubbed it with my finger, and it went away.
     

Share This Page