Default Font

Discussion in 'Mac Basics and Help' started by bthom70, Feb 15, 2006.

  1. bthom70 macrumors member

    Joined:
    May 10, 2005
    Location:
    Danbury, CT
    #1
    OK newbie switcher/slider here.
    I use both XP and OSX.

    I'm a Grad School student and do ALOT of research on the web.
    I often have to copy and past text and URL's into my papers.
    When I copy the text from Firefox into Office 2004 Word it copies in using font Lucida Grande.
    I then have to change it to Times Roman or something else.
    How do I change the font in OSX?
     
  2. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #2
    Use Paste Special... (and choose Unformatted Text) instead of Paste...
    ...or Paste all those links into a text editor and Copy them (again) from there and Paste into Word...
    ...or just Paste the links into Word, then select all text (cmd-A) and set the font to whatever you want...
     
  3. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #3
    In Word 2004, a little clipboard icon should show up when you paste something. If you aren't seeing that, go into Word prefereneces, pick Edit from the left-hand column, and turn on the "Show Paste Options buttons" checkbox.

    When you paste, you can click on that icon and pick either "Match Destination Formatting" or "Keep Text Only" to avoid the font mismatch problem (which is really a Firefox issue).
     
  4. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #4
    Cool... I've never seen that one... much better than my suggestions... :)

    My only excuse: I rarely use Word for anything these days... ;)
     
  5. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #5
    The weird part is that Firefox bothers to assign a font at all, when it's not really preserving the original formatting. It doesn't have to do it that way.

    For a better-behaved example, type up some stuff in TextEdit and choose Make Plain Text from the Format menu, then copy and paste that text into Word: no weird font issues! That's the kind of stuff Firefox ought to put into the clipboard, it it's not going to try to preserve everything like Safari.
     
  6. bthom70 thread starter macrumors member

    Joined:
    May 10, 2005
    Location:
    Danbury, CT
    #6
    I'll give your suggestions a try later.
    But I find it weird that when copy/paste in XP and Firefox it copies fine.
    Except for the odd website that uses an obscure font, then it would use that font, normally a copy/past would paste as time new roman.

    How do I do past special? key combo?
     

Share This Page