Default permissions in shared folder

Discussion in 'OS X' started by wesg, Apr 30, 2008.

  1. macrumors regular

    wesg

    Joined:
    Jan 2, 2008
    Location:
    Toronto, ON
    #1
    I have a small network that includes 3 Macs, all with different OSes (Panther, Tiger, Leopard). The Panther system is set up to share the public folder for everyone on the network. I'm not concerned about security in this folder, I want every file to have read/write for everyone.

    So far this hasn't happened. Whenever a new file is saved or transferred from a different computer, the Panther system can't write to it.

    How can I change the folder so that every file is automatically given the full read/write permissions?
     
  2. McGiord, Apr 30, 2008
    Last edited: Jan 30, 2011

    macrumors 68040

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #2
    Someone correct me if I'm wrong , but I think if you use that shared folder in an external volume, I believe the Finder by default will not care about the ownerships and that is also modifiable.
    ________
    macintosh games
     
  3. thread starter macrumors regular

    wesg

    Joined:
    Jan 2, 2008
    Location:
    Toronto, ON
    #3
    You're right, McGiord, that's the "ignore ownership on this volume" command.

    My problem is that the public folder is on the startup drive, inside the user folder. Ideally I would use an external drive, but I don't have a drive available.
     
  4. McGiord, Apr 30, 2008
    Last edited: Jan 30, 2011

    macrumors 68040

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #4
    I am reading about this in the MacOSX support essentials book.
    I think you'll need to use the ACL access control lists, and the chmod + the sticky bit for the shared folder, command via Terminal, are you familiar with that?
    ________
    amber trichomes
     
  5. thread starter macrumors regular

    wesg

    Joined:
    Jan 2, 2008
    Location:
    Toronto, ON
    #5
    I haven't memorized it yet, but I'm good at learning.
     
  6. McGiord, Apr 30, 2008
    Last edited: Jan 30, 2011

    macrumors 68040

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #6
    As you may notice I'm also learning, so go with caution.

    First see what are the permissions that your shared folder has.

    Open the Terminal app.

    Then navigate up to the directory where you have your shared folder, and type this over the Terminal:

    ls -le

    This will show you what are the permission set for all what is inside your that folder.
    ________
    vapir oxygen vaporizer
     
  7. McGiord, Apr 30, 2008
    Last edited: Jan 30, 2011

    macrumors 68040

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #7
    You may need to disable the sticky bit special permission for the /Users/Shared folder so anyone can access and modify all the files inside that folder.

    The sticky bit gives the special characteristic that the files placed there can only be deleted by the owner of the file.
    ________
    Austro-Daimler
     

Share This Page